Support » Plugin: All in One SEO Pack » Sitemap white page after update

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    Try these steps to look for a conflict with another plugin or your theme.
    https://semperplugins.com/documentation/how-to-troubleshoot-issues-with-all-in-one-seo-pack/

    Plugin Author Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    @system90

    We’re still unable to reproduce this issue. So that we can look into this better and get a fix out quickly for you, please contact us here and reference this thread: https://semperplugins.com/contact/

    I haven’t premium version.
    This plugin and other plugin I use since 2014, but only now after update I’ve this problem.
    With Chrome I see white page.
    With Firefox I get this error

    Errore interpretazione XML: non well-formed
    Indirizzo: https://www.dundi.it/sitemap_post.xml
    Riga numero 2518, colonna 82:			<image:loc>https://www.shotcut.org/assets/img/screenshots/dualmon&speakers.png</image:loc>

    I tried to delete the images but every time I get same error with other image

    • This reply was modified 10 months, 3 weeks ago by  .
    Plugin Author wpsmort

    (@wpsmort)

    This is most likely a memory issue. We’ll have a release soon that optimizes memory usage, but we recommend taking the following steps in the meantime:

    1) In the XML Sitemap module, enable the Sitemap Indexes option, then enable paginate sitemap indexes. In “Maximum Posts Per Sitemap,” choose a low enough number that you don’t run out of memory and your sitemap works. It may be 1,000 or it may be 10,000.

    2) Increase PHP memory to 256 or even 512 https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Either of these should fix it.

    1. I’ve only 666 posts, I tried but don’t work.

    2. I’ve Increase PHP memory until 512M but don’t work

    Thanks

    • This reply was modified 10 months, 3 weeks ago by  .
    • This reply was modified 10 months, 3 weeks ago by  .
    Plugin Author wpsmort

    (@wpsmort)

    You’ll need to set the Maximum Posts Per Sitemap low enough that PHP doesn’t run out of memory when creating the sitemap. You may want to consider unchecking the Media / Attachments post type as this is not needed and just adds considerable number of URLs to the sitemap. Your sitemap is there, only humans see a white screen, search engines see the source code which is fine.

    I don’t see any XML: non well-formed error, where exactly are you seeing that?

    This is my sitemap settings immage I never indexing Media / Attachments.

    Google Search Console can’t see sitemap and I get error.

    If you open this page with Firefox you can see well-formed error

    define( ‘WP_MEMORY_LIMIT’, ‘256M’ );

    After some digging, I think I have found one possible cause (for me anyway) of a sitemap not loading (white page) when not using indexed pages. For me, it is on all sites using Amazon campaign links, such as this:

    ‘https://ir-na.amazon-adsystem.com/e/ir?t=whizbuzwp-20&l=li2&o=1&a=B002QQ7NU6</image:loc>’

    When set to use indexed pages, these same links are causing the parsing errors for me on Webmaster Tools.

    On a couple of sites where I have no campaign URL’s all is fine with the latest version.

    Not sure this is going to help find a fix, but I thought I would share my findings.

    Also worth noting, that doing a rollback to version 2.3.16 fixes all errors.

    • This reply was modified 10 months, 3 weeks ago by  bobsled.

    I’ve do rollback and now work.

    Thank you so much

    • This reply was modified 10 months, 3 weeks ago by  .
    Plugin Author Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    Version 2.4.1 has been released and and should fix the sitemap issues.

    There are two possible issues that some sites had with 2.4:

    1) Running out of memory. If you had this issue, you’d know it because your sitemap would be blank. We now recommend using the Sitemap Index option and setting your Posts per Sitemap Page option to 1000 instead of 50,000.

    2) Parsing error in Google Search Console. This was due to some sites with code that used fake images (Amazon affiliate link code was a common one, but it could be different for everyone). This code fooled AIOSEOP into thinking it was an image, which got included in the sitemap, which caused a parsing error. This is now fixed.

    *Note: any temporary glitch in your sitemap would have no negative effect on your SEO.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Sitemap white page after update’ is closed to new replies.