• Resolved omris83

    (@omris83)


    No idea why but on a new site with AIO SEO, the robots.txt file is displaying like this

    User-agent: *
    Allow: /wp-admin/admin-ajax.php
    Disallow: /wp-admin/ Sitemap: https://www.domain.com/sitemap.xml
    Sitemap: https://www.domain.com/sitemap.rss

    This is causing indexing issues. I have no idea why its disallow?

    If I go to tools and preview, its different:

    User-agent: *
    
    Allow: /wp-admin/admin-ajax.php
    
    Disallow: /wp-admin/
    
    Sitemap: https://www.domain.com/sitemap.xml
    
    Sitemap: https://www.domain.com/sitemap.rss
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author arnaudbroes

    (@arnaudbroes)

    Hey @omris83,

    We can’t reproduce this.

    Do you have any other plugins running on that site? There’s probably something else that is filtering the robots.txt content (we hook into the robots.txt that WordPress Core generates, and other plugins can do this too).

    Thread Starter omris83

    (@omris83)

    Hi @arnaudbroes

    Normally there would be more but on this site, very very little.

    All-in-One WP Migration – Cant be this as use it on every site.
    Breadcrumb NavXT – from theme
    Contact Form 7 – not this as use it on most sites
    Duplicate Page – as above
    KeyDesign Addon – from theme
    Redux – from theme
    SiteGround Optimizer – have this on every site
    WPBakery Page Builder – not this

    So very weird as its very limited on plugins so no idea whats doing it.

    Thread Starter omris83

    (@omris83)

    Hi @arnaudbroes

    Weird. Just disabled AIO SEO and enabled it again, and the problem has gone away. Didnt think of trying this before.

    Thanks for the reply though 🙂

    Plugin Author arnaudbroes

    (@arnaudbroes)

    Awesome, thank you for letting us know you were able to resolve this!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.