Support » Plugin: Yoast SEO » Sitemap not showing

  • Resolved travisbarker

    (@travisbarker)


    Sitemap pages not showing. Hierarchy on parent page shows, usually, but has disappeared today several times as well.

    Google search console also indicates the following 404 error:

    We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.
    1
    General HTTP error: 404 not found
    HTTP Error: 404

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We looked at your provided sitemap and we can confirm the sitemap is generating the URLs correctly. However, it is blank due to the XSL stylesheet. The XSL stylesheet is showing the following error in the browser console:

    Failed to load resource: net::ERR_SPDY_PROTOCOL_ERROR

    If you are wanting to fix the blank sitemap issue, we suggest you please perform a conflict check first.

    Alternatively, you can ignore it since the sitemap is technically correct. You can view the source of your sitemap to verify this.

    Thanks. A bit disappointing how often I see this issue is reported. Google console is indicating a 404 error so want to make sure the pages are being indexed. At the moment it appears they are not.

    Reviewed source code for post page sitemap

    view-source:innovatevancouver.org/post-sitemap.xml
    Indicates 65 posts but I actually have 93. This is likely due to having a few of the other pages locked, but not hidden. But would have liked these on the sitemap even if Google doesn’t index all of them.

    Will contact site host to consult on the other issue of sitemap visibility

    • This reply was modified 1 year, 11 months ago by travisbarker.
    • This reply was modified 1 year, 11 months ago by travisbarker.

    Tested half of the plugins. With the last one, ithemes security (which is probably unrelated since it is not a complete fix,and may only be temporary), I see the main sitemap page appearing consistently.

    The favicon on the main sitemap page is wrong but the sitemap is accurate, and the page is secure. With one more step I was able to also see the post sitemap although its favicon is also still wrong.

    • This reply was modified 1 year, 11 months ago by travisbarker.
    • This reply was modified 1 year, 11 months ago by travisbarker.
    • This reply was modified 1 year, 11 months ago by travisbarker.

    Sitemaps not visible. Sitemap’ Index on google search console improved greatly once the style sheets were updated.

    Hi Travisbarker,

    what exactly did you do to fix the problem?
    I found I have a Yoast sitemap_index.xml problem caused by iThemes Security – or what I suppose, with one of its security settings.

    I got a:
    “error on line 1 at column 87: XML declaration allowed only at the start of the document”

    So, what exactly did you do to fix the problem?

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Sitemap not showing’ is closed to new replies.