Support » Plugin: Google XML Sitemaps » Sitemap not found – error on line 2

  • Resolved Richard Coleman



    I have an issue with a sitemap. Currently using Yoast to generate the maps.

    When I go to retrieve the sitemaps, I get this error – error on line 2 at column 6: XML declaration allowed only at the start of the document

    I don’t know where to locate the file to fix what I believe is a whitespace in the code here.

    Would really appreciate some direction on this.


Viewing 3 replies - 1 through 3 (of 3 total)
  • I sorted it out. Thanks.

    Hello @richard-coleman

    Could you please explain how you solved it? I got the same error and I tried 2 different plugins.

    Thank you

    Hi Folks,

    I discovered it was a clash with another plugin in this instance.

    I was using Project Supremacy 3 which caused the error.

    I removed the plugin and it worked.

    Might be the same for you. I would say turn them all off and start activating one by one to see if that’s the cause.


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Sitemap not found – error on line 2’ is closed to new replies.