WordPress.org

Support

Support » Plugins and Hacks » Sitemap no longer being generated or found?

Sitemap no longer being generated or found?

  • I just realized I’m only getting like 3 or 4 articles out of every 20 I post getting syndicated to Google News. I think my sitemap is not generating correctly.

    Site is AlpineZone.com, url should be alpinezone.com/sitemap-news.xml.

    I’m not seeing anything.

    Also, I do see sitemap.xml but it seems very abbreviated, is that because itonly shows deltas within a certain time frame? I know this definitely used to work, so I’m not sure if there is a conflict.

    Thanks in advance.

    http://wordpress.org/plugins/xml-sitemap-feed/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hey! The same thing is happening to me.

    I keep getting a 404

    Any help to rectify this would be awesome.

    Plugin Author RavanH

    @ravanh

    @parafly9 – could you please try to resave the permalink settings? Go to Settings > Permalinks and just save the options without changing anything. Let me know if that changes anything or not…

    @n3rdabl3 – you seem to be running two xml sitemap plugins at the same time. Please either disable my XML Sitemap Feeds plugin or disable the Sitemap option in Yoast’s WordPress SEO plugin.

    @ravanh – You’re a life saver! Thank you!

    Thanks @ravanh, tried saving the options, didn’t seem to fix anything. TIA

    Plugin Author RavanH

    @ravanh

    @parafly9 for the news sitemap to show anything you need to have content that is not older than 2 days. The regular sitemap.xml seems to work fine but not the post sitemaps split by year…

    The full posts sitemap on sitemap-posttype-post.xml does work, indicating the issue is specific to the date (year) in the URL. There is some kind of redirection to the home page happening but I do not know why or by what.

    Similarly, a manual request for a simple (yearly) date archive like /2013/ results in a redirection to the home page. Maybe a rule in your .htaccess that gets applied? Or some other plugin?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Sitemap no longer being generated or found?’ is closed to new replies.