Support » Plugin: Jetpack by WordPress.com » Sitemap is not working

  • Resolved ahmedus

    (@ahmedus)


    Hi,

    Today I noticed that the sitemap on my website is not working. I entered 2 new posts, but there is still just a warning message.

    No sitemap found. Maybe it’s being generated. Please try again later.

    There is no other plugin activated that generates a sitemap. Also I have no idea if the problem started after upgrading JetPack to version 4.8.2. Btw, News Sitemap has no issues, it works as intended.

    http://ahmedus.blog/sitemap.xml

    Thanks in advance.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you try to go to Jetpack > Settings > Traffic, deactivate the Sitemaps feature, and then activate it back?

    Let me know if it helps.

    Hi Jeremy,

    Thanks for your reply.

    I tried as did several times before, but nothing changed.

    I am having the same issue. https://www.apination.com/sitemap.xml
    and also tried deactivating it and turning it back on. In google webmaster tools, it shows the issue appeared on April 7th

    Even I have the same issue.

    “No sitemap found. Maybe it’s being generated. Please try again later.”

    My page refreshed after ten minutes – with all my past requested populating at once.
    Sitemap looks great.

    • This reply was modified 3 years, 3 months ago by irish_guy. Reason: I no longer had the error
    Plugin Contributor Lisa Schuyler

    (@lschuyler)

    @ahmedus:

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

    It’s as follows.
    http://ahmedus.blog

    Plugin Contributor Lisa Schuyler

    (@lschuyler)

    Hi @ahmedus!

    The Jetpack/WordPress.com sync system is delayed with your site and we’re seeing a large cron backup on your site. I’m not sure that is related to the sitemap issue, but let’s tackle it first in case it has an impact.

    Can you install the WP Crontrol plugin?
    https://wordpress.org/plugins/wp-crontrol/

    That will give you a Tools > Cron Events page where you can see all scheduled events on your site.

    If there are a lot of events scheduled for “now” or overdue, can you reach out to your host to have them check to make sure cron is working?

    You can also try implementing an alternate cron to help fix this:

    https://codex.wordpress.org/Editing_wp-config.php#Alternative_Cron

    Further, please make sure this is NOT present in your wp-config.php file:

    define( ‘DISABLE_WP_CRON’, true );

    Once you’ve done this, let me know so I can check to see if that cleared our syncing mechanism.

    Plugin Contributor Lisa Schuyler

    (@lschuyler)

    @michael_inc

    Looking into your report. Not seeing an obvious cause. Have you tried temporarily disabling your other plugins, leaving just Jetpack installed, to see if the sitemap works then? Let me know how that goes.

    @pinaldave:
    What is your URL? I’ll take a look. If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.com/contact-support/

    Thanks!

    Hi @lschuyler,
    I still have problem after disabling and enabling it and disabling the cache. I have reached out to you via support link.

    Hi @lschuyler,

    I installed WP Crontrol plugin.

    If I click Tools > Cron Events, I see “503 Service Unavailable” error. Cron is not disabled in my wp-config.php file.

    BTW, Settings > Cron Schedules shows the following.

    jetpack_sync_interval 300 (5 minutes)
    minutes_10 600 (10 minutes)
    hourly 3600 (1 hour)
    sitemap-interval 43200 (12 hours)
    twicedaily 43200 (12 hours)
    daily 86400 (1 day)
    wpo_daily 86400 (1 day)
    wpo_weekly 604800 (1 week)
    weekly 604800 (1 week)
    wpo_otherweekly 1209600 (2 weeks)
    wpo_monthly 2592000 (1 month)

    Hi,

    I contacted my host provider and learnt that the host allows hourly scheduled events at most.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @ahmedus Could you add the following to your site’s wp-config.php file?

    
    define( 'WP_DEBUG', true );
    
    if ( WP_DEBUG ) {
    
            @error_reporting( E_ALL );
            @ini_set( 'log_errors', true );
            @ini_set( 'log_errors_max_len', '0' );
    
            define( 'WP_DEBUG_LOG', true );
            define( 'WP_DEBUG_DISPLAY', false );
            define( 'CONCATENATE_SCRIPTS', false );
            define( 'SAVEQUERIES', true );
    
    }
    

    Your wp-config.php file may already include a line that says “define(‘WP_DEBUG’, false);”. You can remove it, and replace it by the code above.

    Once you’ve done so, disable / re-enable the Sitemaps module via the old module list interface, and then check the wp-content/debug.log file for errors. You can paste the results here. You can then replace define('WP_DEBUG', true); by define('WP_DEBUG', false); in the code above.

    Thanks!

    Hi Jeremy,

    I added the code to the wp-config file, restarted the Sitemaps module and also clicked the sitemap files (sitemap, news-sitemap).

    The only thing in the log file is related to news-sitemap.

    [27-Apr-2017 12:30:17 UTC] jp-sitemap-wcKkd: Beginning news sitemap generation.
    [27-Apr-2017 12:30:17 UTC] jp-sitemap-wcKkd: End news sitemap generation. 0.031 seconds elapsed.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thanks for giving it a try. At this point I’d like to run some more tests on your site with you. Could you contact us via this contact form and mention this thread?

    Thanks!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Sitemap is not working’ is closed to new replies.