• Resolved Todd Stratton

    (@boofola)


    I love this plugin! I personally feel that it is much better than the one that sounds like Toast.

    I am getting an empty XML sitemap, but yet the RSS is working fine.

    I have tried turning the feature on and off, I have clicked the reset settings. I have deactivated and then reactivated the plugin. I even went as far as to remove the plugin, restart my server (VPS) and then re-install. None of this has worked.

    I had to install a different plugin to use right now for the sitemap.

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support wpsmort

    (@wpsmort)

    @boofola Unfortunately I can’t help you whilst you are using a different plugin to generate your sitemap. I have to see the problem to help you.

    The most likely cause is that the XSL stylesheet isn’t loading because SSL isn’t implemented correctly so the stylesheet loads from HTTP and then the browser blocks it.

    You can easily test this by opening the browser error console and loading the sitemap. If you see an error about the XSL stylesheet was blocked then you have your answer. The good news is that search engines don’t need to load the stylesheet so they still see your XML Sitemap. The stylesheet is only there to load a pretty version for humans.

    Thread Starter Todd Stratton

    (@boofola)

    @wpsmort Thank you for your response.

    This time when I reactivated the All-In-One sitemap feature, it is all working again.

    I do not know what was causing this issue, but as long as it is working then all is good!

    Thank you again for your help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Sitemap is Empty?’ is closed to new replies.