Support » Plugin: The SEO Framework » Sitemap 404

  • Resolved Vovi

    (@rossdav)


    Looking through the Search Console I realised that the sitemap.xml file is now 404ing on this site. I know it was working when the site went live so an update or some other change has impacted it.

    I’ve treied resaving permalinks and there are no redrects in my .htaccess

    Not sure what to do to get this working again.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Pierre LeBaux

    (@lebaux)

    Solution bellow.

    • This reply was modified 4 months, 4 weeks ago by Pierre LeBaux. Reason: Double post
    Plugin Author Sybre Waaijer

    (@cybr)

    Hello!

    Edit: whoops, I see @lebaux got here before I did! There is some new behavior in the plugin I forgot to communicate well (and it’s quite complex). But, that’s OK 🙂

    I see you have a plugin/theme/snippet active, which redirects plausible 404 pages to /page-not-found/.

    I suggest deactivating that module. Not only because it conflicts with the sitemap, but also because it’ll make it impossible for you to find and debug 404 links via Google Analytics.

    I understand that you might have done this so to create a custom 404 template; but, it’s best to do that via a child-theme instead, and maintain default WordPress behavior.

    • This reply was modified 4 months, 4 weeks ago by Sybre Waaijer.

    OK, disabling the 404 snippet has fixed it …thanks.

    Plugin Author Sybre Waaijer

    (@cybr)

    I’m glad that worked 🙂

    Have a nice day!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.