Support » Plugin: SiteGuard WP Plugin » siteguard-htaccess.php更新時エラー

  • SiteGuard WP Pluginのバグ報告です。
    SiteGuard WP Plugin
    バージョン 1.5.2

    【現象】
    XMLRPC防御をONにする際、.htaccessへの書き込み権限がないと下記エラーが表示される
    Notice: Use of undefined constant path - assumed 'path' in /var/www/hogehoge.com/wp-content/plugins/siteguard/classes/siteguard-htaccess.php on line 109

    【対応】
    /plugins/siteguard/classes/siteguard-htaccess.php
    109行目付近で、「path」に「$」がないので、エラーになるようです。

    if ( ! is_writable( $path ) ) {
    	siteguard_error_log( 'directory not writable: ' . path );
    	return false;
    }

    ご確認いただきますようお願い申し上げます。

Viewing 1 replies (of 1 total)
  • Plugin Author jp-secure

    (@jp-secure)

    noahnaka さん

    こんにちは。

    大変遅くなりましたが、ご連絡ありがとうございました。
    不具合を確認しました。次期バージョンで修正いたします。

    今後とも、よろしくお願い致します。

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.