Support » Plugin: Wordfence Security » SiteGround hosting oddities?

  • Resolved Sue

    (@suelaren)


    I have a hosting account for my website at SiteGround, and two add on domains with WordPress sites that I host. All use WordFence, and all have had issues with getting Firewall configured and working. I was waiting patiently for the maintenance update with a fix…

    This morning I was checking all my WF and WAF installs, Learning mode on for the majority, and lo and behold, Learning mode is ON for all three SiteGround sites, and it appears to have been set up! The odd part is, the warning to configure is still there as well. And, the Learning mode is set to turn off on 4/19, as if I’d set it up two days ago (when I originally tried to do this).

    The php.ini and .htaccess files appear to have the proper lines added for the Firewall to work – I just don’t know if it is working or not. How can I tell? Does the Learning Mode screen mean it is working? Why is the “CLICK HERE TO CONFIGURE” still at the top of every admin page?

    https://wordpress.org/plugins/wordfence/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author WFMattR

    (@wfmattr)

    Hi Sue,

    Since your post above, we have clarified this in the plugin, and added a new documentation page:
    Basic WordPress Protection and Extended Protection

    So, Wordfence’s new firewall can block many bad requests by default, but has additional protection if you are able to finish the configuration steps, which lets the firewall run before WordPress itself starts (or any other PHP files that a plugin or theme allows to be accessed directly.)

    -Matt R

    Thank you for all the changes that came with the update 6.1.4 today. All sites are now running the scan with all options checked, and thank you , thank you for the bulk edit options on the whitelist!! Awesome!

    All my sites are now Enabled; the three sites on SiteGround are running Basic Protection and still are not configured for Extended, although the .htaccess and php.ini seem to be configured. All the other sites I manage are on Extended Protection and the Firewall appears to be running properly.

    Again, thanks to you and the dev team for the endless hours I know you have been putting in since the WAF release a week ago.

    Plugin Author WFMattR

    (@wfmattr)

    Thanks for the response and the kind words!

    I know you were on some of the earlier posts we answered, but I don’t remember if any included the SiteGround-specific help included here:
    SiteGround and other hosts without .user.ini support

    We’ve made some edits so it is clearer, but if it still does not help (we’ve heard of a couple sites where it doesn’t), can you go to the new Diagnostics page on the Wordfence menu, and click the “Send Report by Email” button, and enter wftest [at] wordfence.com? There will also be a field to enter your forum username, so I can match it to your post here when you send the report.

    -Matt R

    The instructions are very clear now, and the step I was missing was to add:

    SetEnv PHPRC /home/user/public_html/sitename/php.ini

    to each of the three .htaccess files. Once I did that, the lights were green, (Enabled) and in Extended Protection mode.

    Thanks again – it’s all working!!

    @wfmattr – I also found I needed to add the following further change to the .htacess file to get Extended Protection working on any SiteGround sites:

    SetEnv PHPRC /home/user/public_html/sitename/php.ini

    I’ve also suggested to SiteGround Support that they contact you to see if you can work together to eliminate this issue.

    While the issue is currently solvable by following the extra documentation provided, the steps required would be overwhelming for many WordPress users on SiteGround hosting. Much better for everyone if this can be avoided.

    Plugin Author WFMattR

    (@wfmattr)

    Hi buzztone,

    Thanks for the feedback — we are looking at automating this in an upcoming version already too!

    -Matt R

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘SiteGround hosting oddities?’ is closed to new replies.