• StevenW123

    (@stevenw123)


    Hi,

    I’ve enjoyed using your plugin for two years or so, but I’ve just moved to Siteground for my hosting and I’m getting endless problems. Shield logs me out every couple of minutes and makes me log back in, even though I’m working on the site, so it is not that there’s no activity. I’ve deactivated all my plugins to isolate the cause and it is Shield.

    Are you aware of this?

    Siteground is very popular, so I’m hoping you’ve come across the problem and have a fix, please.

    Thanks,
    Steve

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author One Dollar Plugin

    (@onedollarplugin)

    Hi,

    If you’ve migrated your site, there may be an issue with your IP address source.

    Could you go to General Settings > Plugin Defaults and review your IP address source – click Description to expand the details. The one you want ideally is REMOTE_ADDR.

    If after setting that correctly there’s no change, for now, disable the User Management module as it’s probably a setting in there that’s kicking you out. You could disable each setting in turn until you find the one that’s not working for your site, or the whole module.

    Also, it’d be worth looking at your Audit Trail to see the message that’s being put there as to why you’re being logged-out. If you can share that with us, it’d point to what’s going on.

    Thanks,
    Paul.

    StevenW123

    (@stevenw123)

    Hi Paul,
    Thanks for getting back to me.

    Yes, it’s showing Remote_Addr.

    My audit trail has repeated messages about this login gout problem saying: “Access to an established user session from a different IP address. Logging out.”

    It does give a different IP address to mine, but how can that be when it is ME!? Then, it shows I’ve logged back in and displays my correct IP.

    (The trail only shows a few such events, nowhere near the actual number of times it logged me out incorrectly.)

    Any idea what could be causing it and how to stop it, please?
    Thanks,
    Steve

    Plugin Author Paul

    (@paultgoodchild)

    Likely there’s a plugin that’s calling async requests from your server, probably an image optimisation plugin or something like that. Under user management, unset the lock to ip address setting.

    Is the IP in the audit trail possibly your server ip?

    Normally the plugin excludes your server ip, but with the change in your host, this has meant the IP it’s using is stale. Did the move to a new host happen in the past 24hrs?

    • This reply was modified 1 month ago by  Paul.
    StevenW123

    (@stevenw123)

    Hi Paul,

    I did wonder about the server IP, so asked my host. Still waiting for them to get back to me.

    I use a caching plugin (WP Rocket), but not an image optimization plugin because I use Photoshop. Though Rockt does do lazy loading, etc, if you want to count that as image optimizing.

    No, I migrated to Siteground two weeks ago. Is there something I can do to “refresh” the server IP, just in case, please?

    Thanks,
    Steve

    Plugin Author Paul

    (@paultgoodchild)

    As a result of this issue, we’ve adjusted how the plugin manages this in the event of a server migration, for the next release. The plugin should be updating it automatically every 24hrs, so I can’t explain why yours isn’t doing so. For now, keeping the lock to IP setting off will solve this for you. The other option is to reset the plugin, which is drastic.
    https://icontrolwp.freshdesk.com/support/solutions/articles/3000040181

    Plugin Author Paul

    (@paultgoodchild)

    The latest release, 8.2.2, should hopefully have resolved this problem for your site… and if not, can you check with the host that $_SERVER['SERVER_ADDR'] is being set correcty also.

    StevenW123

    (@stevenw123)

    Thanks, Paul. Appreciate the help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this review.