Support » Localhost Installs » Site works locally but domain name gives error 403

  • Resolved minstu


    Hi I have been trying to resolve this problem for days now. I have read many other threads about permissions and htaccess files and I think I’ve just gotten into a muddle.

    I have installed two completely separate unrelated wordpress sites with separate databases, held locally on our server using WAMP. (Site1 and Site2)

    Both sites work perfectly locally (example: http://localhost/site1/wordpress), both admin section and main site, all fine. But externally when I click on their respective domain names which I have purchased and mapped with A records ( and they both bring back immediate error 403 messages saying access is forbidden.

    I cannot figure out why this is and really need help please.

    Is there at least a list of things that need to be done to enable access?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Max


    So one single WAMP server, and I take it this server has only one IP address, so both the A records for and point to the same IP?

    Did you configure virtual-hosting for the Apache server in WAMP, or did you simply install WordPress into two different subdirectories on your server?

    Hi, yeah one single WAMP server, one IP address and both domains pointed to it.

    I didn’t configure virtual hosting no, I just installed them in different directories C:/wamp/www/site1/wordpress and C:/wamp/www/site2/wordpress

    I know the domains see the server to some extent because if I stop services on the WAMP server the domains just hang. Turn them back on and immediate 403.

    I wasn’t gonna mention this so as not to confuse anyone but, I guess it’s worth mentioning.

    I have a backup of the whole C:\wamp folder with both sites in the same directories etc, an exact copy basically, except that I have done more work building the site in the current one.

    If I replace the current C:\wamp folder with the backup one, the backup one works and connects to the domains. Sort of. So If I use the backup C:\wamp folder in place of the current folder, the domains work and you can access the sites. BUT, they only work in following way:

    Both domains ( and take you to the index page of the www folder (don’t know why), where you get the list of folders contained within, then if you click on wordpress folder yes it takes you to the site. BUT, if you go to and click on the wordpress folder of site2 then you get this:

    And exactly same if you do it other way round,

    I got frustrated with this and just swapped the backup C:\wamp folder for that one (cos I knew it worked fine) and started all over again.

    And that’s where I am now, I’m using the backup C:\wamp folder which works fine in every way, except that when you go to either domain name you just constantly get error 403. I have tried every thing I can find on here to resolve it.

    What the hell is going on with this? 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Site works locally but domain name gives error 403’ is closed to new replies.