WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Site won't open: HTTP Error 500

[Resolved] Site won't open: HTTP Error 500

  • My site is: http://tpemusicotherapie.com

    The site has been working perfectly for a few weeks, but yesterday after I tweaked a few things in the code (on several pages), I reloaded the site and found the HTTP Error 500 page, although the /wp-admin part of the site was working. I talked to my host’s tech support, and they basically said there was a problem with the header file, and with the theme (Arkitect). However it was working well until I made those edits.

    I tried the wordpress debug feature, but it couldn’t read the template. Does anyone have any advice as to what I should do? I can post any code you would want, let me know.

    Many thanks in advance 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • WPyogi

    @wpyogi

    Forum Moderator

    Download a new copy of your theme to your local computer and then via FTP, replace the header.php file with the new copy. If that does not work, again via FTP, delete the theme folder. Then reinstall it. And BTW, you should not be modifying any theme files — if you want to make changes, use a child theme — so that your changes won’t be lost when the theme is updated.

    I will try that and let you know if it works!
    Could you explain to me what a child theme is, and how I can make one? I really needed to change something in that header, so if I could do it in another way without risking these types of errors, it would be a huge help.

    Thanks!

    Wow thank you so much! That fixed the problem, I really appreciate it 🙂

    WPyogi

    @wpyogi

    Forum Moderator

    Great! Sorry, I should have posted this in my earlier thread:

    http://codex.wordpress.org/Child_Themes

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Site won't open: HTTP Error 500’ is closed to new replies.
Skip to toolbar