Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Site will not work after Jetpack plugin update

  • Resolved lisaslifetips

    (@lisaslifetips)


    I received an email that the Jetpack plugin had been updated. The next email (at the same time) was that my site was experiencing issues and had a critical error. I was able to get into recovery mode to deactivate the plugin, I uninstalled and reinstalled but whenever I activate it and get out of recovery mode, the critical error comes back.

Viewing 15 replies - 16 through 30 (of 43 total)
  • adamharkus

    (@adamharkus)

    Further info…

    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.5.3
    Current theme: Twenty Twenty (version 1.5)
    Current plugin: Jetpack by WordPress.com (version 9.2)
    PHP version 7.4.12

    Error Details
    =============
    An error of type E_ERROR was caused in line 80 of the file /home4/adamhark/public_html/wp-content/plugins/jetpack/modules/calypsoify/class.jetpack-calypsoify.php. Error message: Uncaught Error: Class ‘A8C_WPCOM_Masterbar’ not found in /home4/adamhark/public_html/wp-content/plugins/jetpack/modules/calypsoify/class.jetpack-calypsoify.php:80
    Stack trace:
    #0 /home4/adamhark/public_html/wp-content/plugins/jetpack/modules/calypsoify/class.jetpack-calypsoify.php(56): Jetpack_Calypsoify->mock_masterbar_activation()
    #1 /home4/adamhark/public_html/wp-includes/class-wp-hook.php(287): Jetpack_Calypsoify->setup_admin(”)
    #2 /home4/adamhark/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #3 /home4/adamhark/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #4 /home4/adamhark/public_html/wp-admin/admin.php(175): do_action(‘admin_init’)
    #5 {main}
    thrown

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    adamharkus

    (@adamharkus)

    The solution was to download JetPack 9.1 here:

    https://wordpress.org/plugins/jetpack/advanced/

    Install in WordPress and downgrade the Jetpack version to 9.1

    adamharkus

    (@adamharkus)

    I’m now more than a little concerned about going to Jetpack 9.2 now, and also the WordPress 5.6 update 🙁

    adamharkus

    (@adamharkus)

    @jeherve tried the steps you suggested to no avail…

    I’ve installed Jetpack 9.1 and switched off auto-updates, seems fine for now.

    Thread Starter lisaslifetips

    (@lisaslifetips)

    The recovery link no longer works. Only worked for a couple of hours yesterday. The link now brings me to a page that says “Recovery Mode not initialized.” How do I get a new link to disable Jetpack?

    travliv360

    (@travliv360)

    I am facing the same problem as you guys facing and tried installing version 9.1. It working fine now. But what about 9.2 my site continuously asking for an update.

    serengil

    (@serengil)

    I got the same issue. But resuming it doesn’t solve the problem as @jeherve mentioned.

    An error of type E_ERROR was caused in line 80 of the file /home3/theessk8/public_html/wp-content/plugins/jetpack/modules/calypsoify/class.jetpack-calypsoify.php. Error message: Uncaught Error: Class ‘A8C_WPCOM_Masterbar’ not found

    Solution: I removed jetpack plugin. Then, installed Jetpack 9.1 manually. This solves my problem. Do not forget to turn off auto update for plugings.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thank you all for the reports. You can follow our progress on a fix for this issue here:
    https://github.com/Automattic/jetpack/pull/17939

    You should also be able to definitely get rid of the problem by adding the following code snippet to your site:

    add_filter( 'jetpack_tools_to_include', function( $tools ) {
            $index = array_search(
                    'calypsoify/class.jetpack-calypsoify.php',
                    $tools
            );
            if ( $index ) {
                    unset( $tools[$index] );
            }
            return $tools;
    } );

    You can follow a method like this one to add a code snippet to your site:
    https://jetpack.com/support/adding-code-snippets/

    Once you have that code snippet active on your site, you can safely update to Jetpack 9.2.

    adamharkus

    (@adamharkus)

    Will the issue be corrected in v9.3?

    The above solution doesn’t really work for me as I’ve got by so far without snippets and the need for child themes. I want to keep the site as lean as possible.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Will the issue be corrected in v9.3?

    Yes, it will be fixed in the next Jetpack release. That next release may be 9.2.1 and would be available soon, or could be 9.3, currently scheduled for the beginning of January. That’s something we yet have to decide.

    adamharkus

    (@adamharkus)

    @jeherve

    That’s great I have a workaround (9.1) for now. I’ll wait for updates. Glad the issues been identify and hope I’ve helped!

    matthewcparson

    (@matthewcparson)

    I keep getting this error since the latest update:

    Please check your primary site’s Jetpack connection. wp-admin

    I have tried Jetpack’s help docs, and the form for submitting requests does not work. I have tried the WordPress site’s form for submitting support issues and it also will not work. I have screenshots of all these things, but I can’t post them here. I’ve deleted and re-installed Jetpack, and I’m pulling out my hair. I can’t get on to most pages in my site; I can’t upload posts, I can’t check stats, nothing on the back end. Because the only thing on the page is the left side menu and this error. Please help!!!!!

    chiliandtonic

    (@chiliandtonic)

    Looks, like I am having the same issue as everyone here. Can’t access the admin page too. I sure do hope that by morning it will be resolved from Jetpack’s behalf, because none of the fixes offered have helped me.

    freilinger42

    (@freilinger42)

    @jeherve I’ve tried the snippets solution and have activated the snippet for the entire site, but when I try to activate Jetpack 9.2, I continue to get the error. I’ve not used Code Snippets before – is there another step I need to complete to make that work?

    @adamharkus , I’m on Bluehost and I can’t rollback to 9.1 – do you know how I could potentially manually download and activate?

Viewing 15 replies - 16 through 30 (of 43 total)
  • The topic ‘Site will not work after Jetpack plugin update’ is closed to new replies.