Support » Plugin: LifterLMS » Site went down

  • Resolved tlogue

    (@tlogue)



    Was unable to log on to my web site yesterday, and hosting support had to disable all the plugins to allow log in.

    Upon logging in, I reactivated plugins one by one, and found this error when trying to activate LifterLMS>

    Fatal error: Can’t use method return value in write context in /home2/idesigp7/public_html/wtgmerch/wp-content/plugins/lifterlms/includes/admin/class.llms.student.bulk.enroll.php on line 199

Viewing 2 replies - 1 through 2 (of 2 total)
  • Just saw a new update. Updated, got same error code

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @tlogue,

    I am sorry that you’re encountering this error but it’s occurring because you’re site is currently running PHP 5.4 or lower and while WordPress itself will run on 5.2 or higher, LifterLMS is only tested against 5.6 and higher and we do not claim or intend to support 5.5 or lower.

    Old versions of PHP are officially unsupported (http://php.net/eol.php) and leave your site vulnerable to security issues.

    Our system requirements are available here: https://lifterlms.com/docs/minimum-system-requirements-lifterlms/

    We recommend PHP 7.1 or later (that will probably change to 7.2 soon) and WordPress itself recommends 7.2 also: https://wordpress.org/about/requirements/

    Please work with your host to get upgraded to a currently supported version of PHP and you’ll see this error go away and LifterLMS functionality restored.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.