Support » Plugin: Breeze - WordPress Cache Plugin » Site Was Broken when Breeze Activated

  • Hi, I Installed Breeze cache plugin via the add plugin search, it immediately broke site (Internal Server Error) when I activated it. So Renamed Breeze Plugin folders, still broken. I Suspected .htaccess and wp_config.php in /Eng/ folder (site root) may have been altered, but they seem ok. Is there some other files which Breeze changes or appends that I may not be aware of?

    Server Error log:
    Breeze Installed Here:
    1. [Wed Sep 12 03:32:06.393257 2018] [access_compat:error] [pid 10994] [client 193.106.30.98:45246]
    AH01797: client denied by server configuration: html.werone/Marvin.php

    [Wed Sep 12 03:37:25.515565 2018] [core:alert] [pid 11311] [client 109.145.117.93:63503]
    html.werone/eng/.htaccess: ExpiresActive not allowed here, referer: https://werone.co/eng/wp-admin/plugin-install.php?s=Breeze+%E2%80%93+WordPress+Cache+Plugin&tab=search&type=term
    [Wed Sep 12 03:37:29.664755 2018] [core:alert] [pid 11311] [client 66.249.65.169:46487] /var/www/html/home-control.co.uk/html.werone/eng/.htaccess: ExpiresActive not allowed here

    I’ve checked this eng/htaccess is unchanged, also eng/wp_config.php looks ok and checked htaccess in the root

    2. Current Errors from site log:
    werone/eng/.htaccess: RewriteCond: bad argument line ‘%{REQUEST_FILENAME}’

    3. [Wed Sep 12 03:58:54.498896 2018] [core:alert] [pid 11664] [client 54.36.148.190:36462] /html.werone/eng/.htaccess: Invalid command ‘\xef\xbb\xbf’, perhaps misspelled or defined by a module not included in the server configuration

    I’m a little stuck what to do, can you help please ?

    Best Regards

    Ky

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author adeelkhan

    (@adeelkhan)

    Hi

    I have noticed that you have applied redirection on your domain. What I understand is that the .htaccess of your root domain have some rules which are conflicting. Breeze only adds the rule in .htaccess file. Moreover, internal server error 500 is not related to Breeze; it belongs to the server only.

    Hi , Thanks so much for you quick reply.

    Actually I don’t know why Breeze broke the site, it seems to happen with every cache program I’ve tried. When I renamed the Breeze folders and re-edited the htaccess file I found that windows NOTEPAD was introducing some invisible syntax into the file: ‘\xef\xbb\xbf’

    The clue came from here: https://community.invoiceplane.com/t/topic/2206/4

    From Log:
    /html.werone/eng/.htaccess: Invalid command ‘\xef\xbb\xbf’, perhaps misspelled or defined by a module not included in the server configuration

    when I re-saved htaccess with my usual editor (notetab pro) the site started to work again.

    Thanks again!

    Plugin Author adeelkhan

    (@adeelkhan)

    Hi

    First, you make confirm while you remove ‘\xef\xbb\xbf’ from your .htaccess file site work start properly? Actually, \xef\xbb\xbf are three invisible junk characters called the Unicode BOM. In your editor, especially if your editor is Notepad, make sure you’re saving your file without a BOM.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Site Was Broken when Breeze Activated’ is closed to new replies.