WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Site URL changed, admin panel is inaccessible (blog is working) (10 posts)

  1. actheuniv
    Member
    Posted 2 years ago #

    Hi, I built a wp blog before I obtained the domain that I wanted. I installed wp directly in my root directory, so the blog had http://myrootdirectory.com as an address. Now my wished domain has moved to me so I tried to change the Site URL as well as Home URL, following the instructions on http://codex.wordpress.org/Changing_The_Site_URL. I used the 2nd methode using functions.php.

    Since then my blog is still working but I cannot access to the admin panel anymore. Although I type in my id and password, the admin panel doesn't show up. In panic I tried to undo the change using phpMySQL method and wp-config.php method, but it still doesn't do.

    Could anyone can help me?

  2. NEVER EVER give your admin username in a forum. Keep this info safe and private. There is software that will run code on your login page and will eventually "crack" access. Especially if they already know the username.

    Anyways, chances are the SiteURL and HomeURL are still not setup correctly.

    At this point, it's probably something you will need to change in the database.

    If you don't know how to do this, you can use my contact form here:
    http://www.joshlobe.com/contact-me/

    And I'll give you a hand.

  3. actheuniv
    Member
    Posted 2 years ago #

    Thanks Josh for your advice. I edited the text.
    You mean that I had to change something via MySQL?

  4. Well, it sounds like your first method should have worked (assuming you did everything correctly).

    But the only way to make sure that WordPress knows the homeurl and the siteurl (without admin panel access) is through your database.

    You should be able to login to your hosting provider and use PHPMyAdmin to gain access to the database. Then, you will need to look at the wp-options table.

    It is all documented in the same link you included in your first post... down a few sections from the functions.php method.

    Let me know if you still have trouble.

  5. actheuniv
    Member
    Posted 2 years ago #

    Oh, I meant PHPMyAdmin by telling MySQL. Sorry for my confusion.
    Actually I already changed the siteurl and homeurl of wp-options table. (The values are now the URL that I chose to use.) I read the Codex again, but still I don't see what I possibly did wrong.

  6. Are you certain you have the url set correctly? Is your installation in the root directory or in a sub-directory?

  7. actheuniv
    Member
    Posted 2 years ago #

    I installed wp In the root directory.
    Before I changed, siteurl and homeurl were both http://myrootdirectory.com (without www), and via functions.php I changed the both of them into http://www.mynewdomain.com, because I wanted to change the url of pages, too. Thank you Josh that you're helping me.

  8. Hmmm.. I'll need to take a closer look at this.

    Use my contact info in my first post here, and send me the link to your site, as well as the admin username and password.

  9. actheuniv
    Member
    Posted 2 years ago #

    Problem solved: I simply used the backup files of root directory and files in the theme directory. Siteurl and homeurl are changed as I wanted and I can log in to the admin panel. I doubt that the change of URL and the add of favicon caused somehow the problem. Now I don't have a favicon but it doesn't matter.

    Thousands of thanks to Josh for your patience advices!

  10. My pleasure!

Topic Closed

This topic has been closed to new replies.

About this Topic