Support » Theme: GeneratePress » Site title causes trouble in mobile view

  • Resolved T

    (@tenleftfingers)


    Hí,

    Ón mobile view, the site title continues to the right of the page, making the page artificially wide. It’s also not easy to view the title.

    Could the text be put on a new line for mobile, with word wrap also?

    Thanks, great theme.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Leo

    (@leohsiang)

    Hi there,

    Can you disable WP Optimize so I can see the source code better?

    Let me know 🙂

    Thread Starter T

    (@tenleftfingers)

    Done 🙂

    Leo

    (@leohsiang)

    Looks like it’s wrapping now?
    https://www.screencast.com/t/XmH4BbKXM

    Thread Starter T

    (@tenleftfingers)

    Wow, yes it is. Thank’s for looking into this. So the other plugin may have been the cause. I’ll work on that so.

    Thanks again Lea. I’ll leave a review now.

    Leo

    (@leohsiang)

    No problem 🙂

    Thread Starter T

    (@tenleftfingers)

    I spoke too soon 🙂 Somehow the logo got cleared or disabled, making the text wrap as expected. But when I added the site logo back in, the problem came back.

    I’ve disabled minification again so you can see the code, if you don’t mind.

    • This reply was modified 3 months, 2 weeks ago by T.
    ying

    (@yingscarlett)

    Hi T,

    Try add this CSS:

    @media (max-width: 768px) {
        .main-title {
            max-width: fit-content;
        }
    }
    Thread Starter T

    (@tenleftfingers)

    Hí ying,

    I’ve applied your code, but I don’t see a difference on the browsers I’ve tried:

    Safari ón iPhone 12 míní
    Firefox Focus on iPhone mini
    Desktop Firefox using mobile developer tools

    ying

    (@yingscarlett)

    Hum, try this CSS instead:

    .site-branding-container {
        flex: 1;
    }
    Thread Starter T

    (@tenleftfingers)

    Oh that’s absolutely fantastic, thank you ying!! It looks great with any size 🙂 Thanks again!

    ying

    (@yingscarlett)

    Great! You are welcome 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.