WordPress.org

Support

Support » Plugins and Hacks » SeoPress » Site Title and Description disappear on activating SEO Press plugin

Site Title and Description disappear on activating SEO Press plugin

  • knaveenchand

    @knaveenchand

    The site title and description both of them disappear when I activate this plugin. And when I deactivate the plugin, my site title and description is restored and shown correctly on the site.

    Do I need to change anything in my header.php? I am using a child theme of bp-default theme.

    http://wordpress.org/extend/plugins/seopress/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Ben

    @communicatorsinaction

    Same problem here. I would simply replace the title in header.php with my site title (instead of the bloginfo call) except then I would have to do this for each user blog — which is not feasible. I don’t understand why each blog’s site title is stripped upon network activating the plugin (and then replaced upon deactivation, it must be the plugin). I would love to use your plugin, as it appears the best free solution to multi-site SEO, but I’m afraid I can’t until this problem is resolved.

    Ben

    @communicatorsinaction

    After poking around a little bit more, I found out this is because the plugin walks on the bloginfo function. From line 36 in sp-core.php:

    add_filter( 'bloginfo', array( &$this, 'delete_bloginfo_name') , 1, 2 );

    Unfortunately, it uses this to change the meta titles, so if I comment the line out the plugin becomes ineffective. Isn’t there a better way? Or am I missing something completely?

    I’m having the same problem. Id there any fix for this?

    Plugin Author Slava Abakumov

    @slaffik

    SeoPress 1.2.4 (will be released in 10 minutes) should fix this issue. Please upgrade!

    It is still not fixed with 1.2.4 version of SEOPress.

    I have upgraded to 1.2.4 and activated it again but no luck. The site title and description continues to disappear whenever I activate SEOPress plugin. And when I deactivate this plugin, the site title and description appears normally.

    I am using buddypress default theme with latest buddypress plugin and latest wordpress version.

    Please help.

    Same for me – have only just installed the plugin. I’m using Twenty Eleven as my blog theme.

    Same for me. Site title does not show when activated. I installed and detected the issue last night. Hope this gets fixed…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Site Title and Description disappear on activating SEO Press plugin’ is closed to new replies.
Skip to toolbar