Support » Fixing WordPress » Site text missing on Chrome

  • Yesterday I noticed my site ( is loading strangely on Chrome. On an initial load, the site’s text is all missing (or possibly just white rather than black). If you refresh, the site’s text appears. If you mouse over the main header menu, it slowly reveals with the cursor. If you view page source, it refreshes and the text appears.

    Any idea what could be causing this? Some weird CSS incompatibility with Chrome?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Have the same problem, anyone has a idea?



    Forum Moderator

    @irernst: It is considered impolite to interrupt another poster’s ongoing thread unless you are posting a solution or suggestion. It causes significant problems for the forum’s volunteers and prevents us from being able to track issues by topic. Please post your own topic.

    I am having the same issue with our company website at Everything was fine about a week ago, I haven’t even made any changes to the site. In all browsers except Chrome my h1, h2, h3, h4, h5, h6 tags display the text fine. However when you go to our site in Chrome upon initial arrival all heading tags do not display no matter what direct link on our site you go to. The body text is not affect only the heading tags. What’s really weird is if you re-size the window or inspect element or re-hit enter in the address bar or even go to another page on the site and click the back button, everything then appears to run fine in Chrome, it’s just the initial load. I deleted out all my CSS, just to make sure and that did nothing. I de-activated and deleted all my plugins and that didn’t do anything either. Also what’s strange is it displays fine while logged into our wordpress dashboard, but when you log out the issue arises again. I believe something has either re-wrote a script file or may possibly be something with chrome at this point. I went on my computer at home that had an old cache of the site in chrome and it appeared fine, I then cleared my cache to see what would happen and bam the issue appeared. I’m thinking not only did it re-write a script, but maybe a script that pertains to cache. It would also have to be something on wp-admin side because I deactivated our Woo Theme and that didn’t even take care of the issue. Some one please help me, this is frustrating and I have spent many hours trying to troubleshoot…


    Ok everyone I found the answer after reading some more online forums here on WordPress and on Google and by doing some trouble shooting of my own. Every one kept thinking it was a cache issue as I thought the same thing as well, which is partially correct, but it has to do with the 304 return. To read that thread click here That’s why upon reload sometimes it works and sometimes it doesn’t. The funny thing about this issue is that it’s a simple fix. So simple everyone is going to scream when they find out how to resolve the issue for now. The issue is Google fonts. If you have Google Fonts or even a different font-face file loaded into your theme then you will have this issue currently in Chrome. It is a bug with the current version of Google Chrome. I have read that if you download the new beta Chrome Canary the issue has been resolved. To fix the issue simply change your text to a web safe font. I changed ours to standard Arial font and everything now works perfect and loads perfect. Also remember if you are using any inline font-style short codes you will need to change the font-style as well to a web safe font. Once everyone has changed over to the new Chrome or if Google fixes this bug will I then change back to custom fonts. Also if you are using a theme make sure to check all your misc-typography fonts and widget fonts for those will be effected as well. I hope this help you all!!! [advertisment removed]

    Hi jkovach,

    It’s not Google fonts that are the cause of the issue, it’s an old version of FitVids. I had a look at your site and you are using FitVids 1.0 (in this file: ) if you update that to the latest version (currently 1.1) it will fix your issue.

    I know this is the issue because I’m not using Google Fonts but had the same issue, and as soon as I updated FitVids the issue was fixed.

    Give it a go, and you can keep your fonts!


    can you please explain to me why it would be a FitVids issue, based off what I have read at the link you provided me FitVids is “A lightweight, easy-to-use jQuery plugin for fluid width video embeds.” How does this have anything to do with Text missing?

    Well I updated the FitVids to 1.1


    and it seems to have worked… Thanks for letting me know!!!
    If you have any insight as to why this update fix the issue please let me know…I am nerdy like that and must have more knowledge

    I’m not sure why it worked, I just did lots of trial and error, removing scripts until I found what was causing it, and it was FitVids.

    I had this issue and deactivating Google Fonts fixed it. I did not have FitVid installed.

    I have this problem in mobile version of my website. Sometime text disappear. Can someone help me.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Site text missing on Chrome’ is closed to new replies.