Support » Fixing WordPress » site stop sending email

  • Resolved fonnte

    (@fonnte)


    hello,

    yesterday i updated my wp to 4.6. today i am realizing that i don’t receive email from my site anymore (user registration, jetpack form, updated post by user : it used to be at least total 10 emails/day). i have asked my hosting provider and they have not see any problem.

    i can receive email from other email and send one. but not receiving from my site after this update. any idea how to fix it?

    thank you

Viewing 15 replies - 1 through 15 (of 21 total)
  • I have exactly the same problem with one of my sites, no notifications or anything are coming through any more….

    Any help would be great

    for more information, i have found this on my log and my website is hargamobilmu.com

    [16-Aug-2016 07:02:57 UTC] WordPress database error Table
    ‘mydatabase.wp_weu_user_notification’ doesn’t exist for query SELECT
    template_value, email_for,email_by,email_value FROM
    wp_weu_user_notification WHERE email_for = ‘New Comment Post’ made by
    wp_handle_comment_submission, wp_new_comment, do_action(‘comment_post’),
    call_user_func_array, show_message_function
    [16-Aug-2016 07:02:57 UTC] PHP Warning: array_push() expects parameter
    1 to be array, boolean given in
    /home/xxx/public_html/wp-content/plugins/wp-email-users/wp-email-users.php
    on line 480
    [16-Aug-2016 10:33:30 UTC] WordPress database error Table
    ‘mydatabase.wp_weu_user_notification’ doesn’t exist for query SELECT
    template_value, email_for,email_by,email_value FROM
    wp_weu_user_notification WHERE email_for = ‘New User Register’ made by
    require(‘wp-blog-header.php’), wp, WP->main, do_action_ref_array,
    call_user_func_array, WPUM_Form_Register::process,
    WPUM_Form_Register::do_registration,
    WPUM_Form_Register::random_psw_registration, wp_create_user,
    wp_insert_user, do_action(‘user_register’), call_user_func_array,
    wp_registration_send
    [16-Aug-2016 15:27:06 UTC] WordPress database error Table
    ‘mydatabase.wp_weu_user_notification’ doesn’t exist for query SELECT
    template_value, email_for,email_by,email_value FROM
    wp_weu_user_notification WHERE email_for = ‘New Comment Post’ made by
    wp_handle_comment_submission, wp_new_comment, do_action(‘comment_post’),
    call_user_func_array, show_message_function
    [16-Aug-2016 15:27:06 UTC] PHP Warning: array_push() expects parameter
    1 to be array, boolean given in
    /home/xxx/public_html/wp-content/plugins/wp-email-users/wp-email-users.php
    on line 480
    [16-Aug-2016 16:57:42 UTC] WordPress database error Table
    ‘mydatabase.wp_weu_user_notification’ doesn’t exist for query SELECT
    template_value, email_for,email_by,email_value FROM
    wp_weu_user_notification WHERE email_for = ‘New User Register’ made by
    require(‘wp-blog-header.php’), wp, WP->main, do_action_ref_array,
    call_user_func_array, WPUM_Form_Register::process,
    WPUM_Form_Register::do_registration,
    WPUM_Form_Register::random_psw_registration, wp_create_user,
    wp_insert_user, do_action(‘user_register’), call_user_func_array,
    wp_registration_send

    i haven’t got any error from updates before. my plugin and themes are all updated too. thank you

    wp_weu_user_notification is not a table that belongs to WordPress core.

    PHP Warning: array_push() expects parameter 1 to be array, boolean given in /home/xxx/public_html/wp-content/plugins/wp-email-users/wp-email-users.php
    on line 480

    That sounds like a bug in the WP Email Users plugin you’re using. Try contacting its developer to make them aware of it.

    Have you tried deactivating the plugin to see if sending emails works again?

    In addition to that, what’s the domain & name of your site? This would help us track down the issue.

    No I have deactivated contact form7 it doesn’t seem to have an effect on the admin sending me any notifications…

    Going to backdate wordpress and see if this has an effect.

    So I have deactivated all plugins too, just for everyones note, this has not fixed the problem…

    hi @pascal Birchler,

    i have mentioned my website above, it’s hargamobilmu.com. i have deactivate and delete all email based plugin (Email Users
    and Easy WP SMTP) while i am not deactivating wp user plugin yet (and stil activated until i write this), and the mail is start coming again.

    maybe the bug is coming from other plugin? but how, if the log says wp email users plugin has bug?

    thank you

    I am also having this problem. Everything worked find until I upgraded to 4.6.

    Me, too. I received notifications every time someone commented, but since I upgraded, that stopped. Email is working in every other way, and people are able to leave comments. But my host tells me that WordPress isn’t initiating emails. It’s not as if the email is going to a spam folder or there is an error message. It’s that WordPress isn’t generating the emails at all.

    Moderator kmessinger

    (@kmessinger)

    Try this plugin to help debug the problem. https://wordpress.org/plugins/check-email/

    You can get rid of it after you see what it says.

    I did fixed the problem.

    Install the WP Mail SMTP plugin and make sure the reply address is a valid email address. I have a special no-reply account to prevent my mailbox from filling up with spam. This applies to any contact form plugins as well. This may be dependent upon your mail server. Let me know if this works.

    thanks @kmessinger and @pascal Birchler

    i’ve tried and no error found. well i don’t know whether the bug is caused by other plugin or else, but i am so glad the mail system has works as it should be by deactivating some plugin.

    thank you for your help

    How do you use the plugin? I set it up, but couldn’t figure out how to run the test.

    just send to your other email. if it sent and received, your mail works

    Sorry — I don’t understand. Send to my other email? I have the plugin installed, but I don’t see a way to use it.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘site stop sending email’ is closed to new replies.