• Resolved steph413

    (@steph413)


    For some reason my site suddenly stopped showing stats on dashboard.
    I’ve tried updating all plugins which hasn’t helped. However, I can see that Jetpack is showing up as blank so I’m suspecting that may be the problem.
    Any help would be amazing. Thanks!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi, Steph!

    Try going to Dashboard > Plugins and Deactivate and then Activate Jetpack plugin. If that is not working, Deactivate and then Delete Jetpack and then Install it again and Activate it.

    Hope this helps!

    Plugin Support Tracy

    (@tmmbecker)

    Hey @steph413! You’re not seeing stats just now because the site is not currently connected to Jetpack. I’d start by following @vladytimy’s brilliant suggestion to deactivate and then reactivate.

    If that doesn’t work, as a next step here, would you please delete Jetpack and then reinstall it?

    This handy guide explains that process in more detail:

    https://jetpack.com/support/reconnecting-reinstalling-jetpack/#reinstalling-jetpack

    Let us know how that goes πŸ™‚

    Thread Starter steph413

    (@steph413)

    Thanks Tracy and Vlad. I tried deleting and reinstalling and it’s still not working…

    • This reply was modified 3 months ago by steph413.
    Plugin Contributor Dan

    (@drawmyface)

    That’s odd. The error we’re seeing is almost always resolved by disconnecting and reconnecting.

    Can you try these steps to clear the Jetpack options from your database?

    1. Go to Jetpack in your site’s dashboard.
    2. Disconnect from Jetpack if it says that you are connected on the Jetpack page.
    2. Deactivate Jetpack on your Plugins page
    3. Install and activate this plugin to remove the Jetpack data from your database: https://github.com/automattic/jetpack-addons/archive/add/jp-rm-options.zip
    4. Check to make sure this plugin is now deactivated and deleted from your site, since it performed its job.
    5. Try to re-activate and connect to Jetpack again.

    Let us know how that goes.

    Thread Starter steph413

    (@steph413)

    Hi Dan,

    Thanks for your reply.
    I installed the plugin but when I tried to activate it, it says the plugin file does not exist.

    Plugin Support Mark Zakariya

    (@mzakariya)

    Thank you for giving that a try, @steph413! Once activated, that small plugin removes Jetpack’s data on your site, and then immediately deletes itself – this might have caused the error you saw.

    Taking a look at things from our side, it looks like Jetpack has been completely removed from your site. You should be able to reinstall it from the Plugins page.

    If you continue to get an error message, please manually remove Jetpack’s files on your site. They are located in this directory:

    /wp-content/plugins/jetpack/

    If you’re not sure how to do that, your hosting provider can do it for you.

    Please let us know if the Stats page continues to be blank – and thank you for continuing to troubleshot this with us! πŸ™‚

    Thread Starter steph413

    (@steph413)

    Hi Mark,
    Thanks for your reply. I’ve reinstalled the Jetpack plugin but that doesn’t seem to have done anything. I’m still not seeing site stats and the homepage of Jetpack is blank.
    Thanks

    Plugin Contributor csonnek

    (@csonnek)

    Happiness Rocketeer πŸš€

    @steph413 thanks for trying that! We’re still showing your site as being disconnected on our end.

    Can you try these steps to troubleshoot your problem?

    Actually, see my reply below for what the issue may be.

    If you’re still having the problem after following these steps, we’ll need to run some tests with you directly to try to figure out what’s happening.

    Could you contact us via this contact form and mention this thread?

    Thanks!

    • This reply was modified 2 months, 3 weeks ago by csonnek. Reason: found the issue after more research
    • This reply was modified 2 months, 3 weeks ago by csonnek.
    Plugin Contributor csonnek

    (@csonnek)

    Happiness Rocketeer πŸš€

    @steph413 I just ran another test on your site and I believe I found the issue.

    It looks like there might also be an issue with our servers verifying your site’s SSL certificate.

    Here’s a report that gives some more details:

    https://www.ssllabs.com/ssltest/analyze.html?d=stephaniehoathlete.com.au&hideResults=on

    It looks like your server doesn’t have the necessary SSL libraries installed to enable “Forward Secrecy”. Without this, certain security protocols fail and Jetpack needs those for authorization.

    To remedy this, I’d recommend contacting your host and asking them to make sure your certificate supports Forward Secrecy.

    If you’re still having trouble after you fix the issue with your SSL certificate, please get in touch using the contact form link above.

    Thanks again.

    Thread Starter steph413

    (@steph413)

    Hi @csonnek
    Thanks for your reply.
    Would you have any recommendations for free SSL certificates that do support forward secrecy? My current one is not set in stone so I’m open to others.
    Thanks!

    Plugin Contributor Ryan C.

    (@ryancowles)

    Hi @steph413! That’s a good question. It looks like your site’s current SSL certificate is provided via Let’s Encrypt, which is who I usually recommend. I’m not aware of current issues with their service and Jetpack.

    Did you setup the SSL certificate on your own? Or did your host set it up for you? If the former, I’d suggest contacting Let’s Encrypt to ask them to look into this further for you. And if the latter, I’d suggest getting in touch with your host.

    Please let us know either way and we’ll go from there!

    Thread Starter steph413

    (@steph413)

    Hi,

    Thanks for your reply.

    I got in contact with Let’s Encrypt and they have suggested to update my list of accepted ciphers. They said my Apache server configuration has no applied cipher preference order; and to use:
    SSLHonorCipherOrder On

    I’m not sure how to do this exactly and I have talked to my host who said that Cipher SSL actually have a lot of directives that can be enabled or disabled and they will need more details of what is required.

    Any help would be much appreciated.
    Thanks.

    Plugin Contributor Ryan C.

    (@ryancowles)

    Thanks for the update! Your server settings are managed by your host. Since they have access to your server, they’ll need to make those changes for you. I’d suggest getting in touch with them once again and specifically asking them to set SSLHonorCipherOrder to On on your server.

    I’m sorry we don’t have more to offer, but since we don’t have access to your site’s server, I’m afraid we can’t make those changes for you. Please let us know what your host says, though!

    Thread Starter steph413

    (@steph413)

    Hi Ryan,

    Thanks for this.

    I contacted my host who said they’re unable to action the above as it would affect their whole server. I was wondering whether you know of any other SSL providers that would support forward secrecy better?

    Thanks,
    Stephanie

    Plugin Contributor Ryan C.

    (@ryancowles)

    Hey, Stephanie! I’m afraid that I’m not very familiar with other free SSL providers. From my perspective, it seems this is less to do with the SSL certificate and more a limitation of your current hosting platform. As such, I would suggest considering a new host.

    You can find a list of hosting recommendations here:

    Alternatively, you could also reach out to Let’s Encrypt to see if they have any other suggestions.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.