WordPress.org

Forums

WP Super Cache
Site speed worse with WP Supercache installed (7 posts)

  1. seasaltweb
    Member
    Posted 1 year ago #

    hi,
    i have just installed WP Supercache to improve site speed, however now my site is even worse. Many pages just continually load and its unbearable. Ive read so many forums and documentation to fix it however Im getting nowhere and it seems to be getting worse.
    I would appreciate any help to resolve this as quickly as possible. The site is http://www.broadland.com.au
    An example of a page not loading is when you're on the home page and click on the button GET MY VOUCHER (which takes you to the page http://www.broadland.com.au/voucher) the page just continually spins and will not load.
    I have the recommended settings turned on and have it set to use PHP. CDN is turned off, preload mode is on.
    I can send you a screenshot of my settings if needed. Thank you!!!

    https://wordpress.org/plugins/wp-super-cache/

  2. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi!

    Well, since you currently have a "Under construction" theme, I don't see what you mention. Could you turn on your regular theme again, and share your settings as well, as you mentioned? Thanks!

  3. seasaltweb
    Member
    Posted 1 year ago #

    Hi Richard,
    Thanks for your reply. Sorry the client asked me to turn off the site as it was unbearable. I have reenabled it. I had deactivated the plugin but have turned it back on now. The settings turned on are:
    - Cache hits to website for quick access
    - Use PHP
    - Compress pages
    - 304 not modified browser caching
    - Cache rebuild - serve supercache file to anon
    - cache timeout 1800
    -Timer 3600 seconds
    - CDN off
    - preload cache files every 100 mins
    - preload all posts
    - preload mode
    - debugging enabled

    Cache tester - timestamps match.

    thanks for your help!

  4. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi!

    So I just took a look, and I asked a few of my colleagues to check as well, and we all found the site slow to load (several seconds) I'm not entirely sure it's because of WP Super Cache, though. A few questions:

    1) Have you tried "Use mod_rewrite to serve cache files" instead of Use PHP ?
    2) If you've already pre-loaded the pages, I'm not sure why you're doing it again every 100 minutes? Does the content change that often?
    3) Is this site on a shared host, or a VPS, or something else?

  5. seasaltweb
    Member
    Posted 1 year ago #

    hi
    1) No but i can do that now. Do i need to modify anything else to use this method?
    2) I wasnt sure what to use so tried 100. Have reset to 2000
    3) Its on shared hosting and have been trying to get the web hosting co. to up the plan but no luck yet.

  6. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi!

    1) nope, that should be it!
    2) I don't think you even need to preload, personally, unless you expect lots of hits all over the site.
    3) Hmm, well, to be honest, the site is slow, and the shared hosting is probably what's doing it. That, and maybe the theme itself; the /blog takes a long time to load, and I suspect it's because of the theme.

    One last suggestion: Have you considered using Jetpack, and the Photon image CDN included in it? Have a look here, and let me know if you have any questions about it; it may help things just that much more for you:

    http://jetpack.me/support/photon/

  7. seasaltweb
    Member
    Posted 12 months ago #

    Thank you Richard. mod_rewrite has made the page speed a bit better. There are just 2 pages that continually spin and take a long time to load (both of these pages have forms on them). One page http://www.broadland.com.au/voucher uses the Salesforce web to lead plugin and the other page http://www.broadland.com.au/subscribe uses a Mailchimp form.

    Should I turn off caching for these 2 pages? The links for both of them are on the home page. Can you please tell me if I should do this and how? Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic