WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Site showing page id instead of page name (9 posts)

  1. iroysport
    Member
    Posted 7 months ago #

    Would you guys please help. I have a site that was build on a multisite platform, if the permalinks are set in default which shows the page id number everything works fine. But if I change the permalink to the page name instead of the page ID its give me a 404 page. Basically it does not work. Do you know how I can change the page back to page name instead of page id number. Thanks

  2. Alin Marcu
    Member
    Posted 7 months ago #

    Are you refreshing the page after changing the permalinks? If yes:

    1. Change the permalink

    2. Go back to your homepage/main blog URL (somedomain.com/blog, blog.somedomain.com or whatever), refresh the homepage

    3. Now start navigating the website, by clicking a link, you should notice the new permalinks

    If you are using any caching plugins make sure you clear the page cache before step 2.

  3. iroysport
    Member
    Posted 7 months ago #

    Yes I am refreshing the page buts its still not coming up. Its just giving me 404 error

  4. Alin Marcu
    Member
    Posted 7 months ago #

    You need to follow the steps described above, you are refreshing the old permalink, is normal to receive a 404 error.

  5. iroysport
    Member
    Posted 7 months ago #

    Just so I am clear the main page comes up just fine. its the other pages that once I click on them they do not show up. After changing permalinks and refreshing the pages its still giving me errors

  6. Alin Marcu
    Member
    Posted 7 months ago #

    When you click a link, the page that gives you a 404 error has the older permalink format or the new one?

  7. iroysport
    Member
    Posted 7 months ago #

    it has the new permalinks, http://www.iroysport.com check out the site now and in in few mins I will updates it and you can see what I am talking about

  8. Alin Marcu
    Member
    Posted 7 months ago #

    To properly test it, you should disable caching and CDNs/Proxies (you're using cloudflare, right?). The home page is randomly responding with different URIs for the same page, because of that.

    Also check the permissions on .htaccess file. You can temporary use 660 or 666 and save the permalinks again, but DON'T FORGET TO REVERT IT BACK TO INITIAL PERMISSIONS!

    You can find more details here: http://codex.wordpress.org/Using_Permalinks

  9. Alin Marcu
    Member
    Posted 7 months ago #

    Looks like it's working fine now!

Reply

You must log in to post.

About this Topic

Tags

No tags yet.