Support » Plugin: W3 Total Cache » Site not working after update

  • Resolved helpfulwebhosting


    We’re having some trouble with one site following the latest release of W3TC.

    At the moment we’re getting this error for normal visitors:
    Fatal error: Call to undefined function wp() in /home/account/public_html/wp-blog-header.php on line 14

    And this error for Dashboard:
    Fatal error: Call to undefined function nocache_headers() in /home/account/public_html/wp-admin/admin.php on line 32

    We have tried disabling all plug-ins via phpMyAdmin by clearing out the array in the options table. That didn’t work, but perhaps revealingly phpMyAdmin reported the action as having done work on ‘[option_name: ACTIVE_PLUGINS – _TRANSIENT_W3TC_REWRITE_TEST_D8C5182AD898453E]’.

    We performed the update on a number of similar sites without any trouble, and it’s hard to say why this one would be any different. Any advice on how to get the site and Dashboard up and running would be very welcome

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Frederick Townes


    Have you tried removing the wp-content dropins? advanced-cache.php, db.php and object-cache.php there has been changes to these files and its possible (but unlikely) it caused wrong loading sequence of WordPress on upgrade.

    Thanks for replying Frederick, I know you must be very busy with this upgrade.

    We had some more wierdness with this particular account so we’re going to wipe it and restore it from and older version.

    If we hit the same problem again when upgrading W3TC on this site after it’s restored I’m sure your advice will come in useful.

    We only had problems with this one site, all our other accounts upgraded perfectly well.

    Plugin Author Frederick Townes


    Any other errors from the error log?

    Sorry Frederick we wiped the old site in preparation to restore a previous version. We don’t have anything in the logs that’s relevant to share.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Site not working after update’ is closed to new replies.