Support » Theme: GeneratePress » Site not mobile friendly with this theme

  • Resolved heath18

    (@heath18)


    I am getting Google errors and need to see if anyone has any suggestions. It may be connected with the theme.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • It renders nice on my phone (tested with Chrome). Can’t see any problem.

    That’s strange. I’m getting errors of clickable items being too close and not everything fitting in the screen. I have screenshots of the errors but can’t figure out how to get it on here.

    Theme Author Tom

    (@edge22)

    Strange, it’s like the mobile test isn’t picking up the CSS.

    Any caching plugins? Cloudflare rocket loader? If so, can you try with those disabled?

    I’ve disabled everything but Hummingbird. I also use Cloud flare but it is the free option. I’m still having the same issues.

    Theme Author Tom

    (@edge22)

    I’m still seeing Rocket Loader activated: https://www.screencast.com/t/9a5hxABhDM

    Can you make sure it’s disabled?

    I don’t know how that is still showing. I don’t have any plugins for cloudflare unless that code isn’t from the plugin and me just using the service.

    Theme Author Tom

    (@edge22)

    I believe Rocket Loader is a setting inside your actual Cloudflare account – not inside your WP Dashboard.

    Ok so just to really test it. I’ve had CloudFlare deactivated. I am still getting the errors. I don’t know what to do.

    Any other suggestions?

    Theme Author Tom

    (@edge22)

    Can you also deactivate Hummingbird, just to test?

    I just did that. Cleared my cache and waited a few minutes and I’m still getting the same errors with about 4 less page rendering errors.

    Also still getting the clickable items too close and too big for screen errors. I don’t get this.

    Theme Author Tom

    (@edge22)

    The main issue that I’m seeing is that the tool isn’t loading the majority of your CSS and JS.

    If you click on “View Details” next to “Page loading issues”, it lists each on it’s not loading.

    Unfortunately, they’re giving us the “Other error” reasoning, which isn’t helpful at all.

    I did some reading, and found this: https://webmasters.stackexchange.com/a/109387

    I wonder if it would help to install a plugin like Autoptimize, which does a great job of combining CSS and JS into only a couple of files. Perhaps this would allow the tester to fully render the page as a regular user does.

    I wonder why that is happening. What is different from my site that it’s doing that to mine and not others? I know you probably don’t know that.

    One other question….where is my main robots.txt? Is it through Yoast or with my host? It seems that could be part of the problem as well.

    Theme Author Tom

    (@edge22)

    It could be your server response time, but that’s just a guess.. Reducing your HTTP requests might fix it?

    Your robots.txt file should be in the root directory of your website along with the wp-admin, wp-content etc.. folders.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Site not mobile friendly with this theme’ is closed to new replies.