Support » Localhost Installs » Site Not Accessable Internally Only Externally

  • Resolved dmcgettigan

    (@dmcgettigan)


    So I have WordPress site on a ubunutu server 16.04, that I can access via url, darrenmcgettigan.tk, from my home pc, but when I try to access it from work, the same network it is on, I get a connection timed out error. Before I changed the WordPress address and the site address I was able to to connect to the site via the internal ip address, 192.168.4.176.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Verify your firewallS allow access. Home firewall – is there more than one? Work firewall? What IP addresses are involved other than the local IP address you mentioned? This isn’t a wordpress issue, it’s a network issue. Ask in a networking or ubuntu forum if these clues don’t help you.

    but when I try to access it from work, the same network it is on, I get a connection timed out error.

    I agree with @apb1963

    Your company network firewall/security appliance may not support NAT loopback. Check with your company IT dept.

    I confirm that this is a network issue. When you lookup the “darrenmcgettigan.tk” you get an IP address that works from the internet side of the bridge/router into the local LAN, BUT does not work when used on the LAN segment.
    The solution is to make your own mapping of name to IP, to do this add this to your HOSTS file on your computer at work (the 2nd line may not be necessary):

    192.168.4.176 darrenmcgettigan.tk
    192.168.4.176 www.darrenmcgettigan.tk

    Details on the HOSTS file here:
    http://en.wikipedia.org/wiki/Hosts_%28file%29

    • This reply was modified 3 years, 1 month ago by RossMitchell.

    Thanks you for the help, changing my hosts file worked, now I just have to change everyone else in the company, lol.

    @dmcgettigan

    changing my hosts file worked..
    ..now I just have to change everyone else in the company

    That’s not really a practical solution for workstations located on a company network. It’s a fine solution for an isolated instance where you need to overcome settings on your own home computer because your router won’t support NAT Loopback, but it’s just a work-around.

    Speak with your IT staff. They may be able to help you with a much better solution, or they may even tell you they don’t allow it. Either way, it’s best to seek their assistance. They will appreciate being kept in the loop. (No pun intended)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Site Not Accessable Internally Only Externally’ is closed to new replies.