WordPress.org

Ready to get started?Download WordPress

Forums

Site migration php issue (2 posts)

  1. captainpant
    Member
    Posted 2 years ago #

    Hi,

    I am very new to all this so apologies for general stupidity.

    I tried to migrate a WP site from one host to another because the original host was terrible.

    I FTPed (Filezilla) a copy of the entire site into the home directory of the new host.

    When I went to the domain I received an error message:

    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /home2/paddlema/public_html/index.php on line 17

    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /home2/paddlema/public_html/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required './wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/paddlema/public_html/index.php on line 17

    I tried to remedy this by creating a wp-blog-header.php text file and FTPing it into the public_html directory.

    All that that achieved was to get me to receive a new, more complicated error message, which you can see at http://www.paddlemag.com

    I have no idea how to fix this and would dearly appreciate some help with it.

    Thanks very much for any help you can provide.

    Simon

  2. s_ha_dum
    Member
    Posted 2 years ago #

    You can't just create a wp-blog-header.php file. It has to be the wp-blog-header that WordPress needs.

    Go back and re-upload everything in case you have missing (which you do) or corrupt files. Don't try to upload everything at once. Upload piecemeal. Upload wp-admin all by itself. Upload wp-includes all by itself. Since both wp-admin and wp-includes both have a lot of files you may even want to upload the subdirectories of each individually. I tell you this because I have had to work with a server that seemed to have issues with large uploads with many subdirectories. Things got lost or corrupted. This somewhat tedious upload procedure got around the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic