WordPress.org

Forums

site Load time + W3 Total cache (8 posts)

  1. siegmich
    Member
    Posted 2 years ago #

    Hi,

    I'm currently setting up my 2nd website and as I'm fairly new to WP I'm running into some problems and this time I can't find the source...

    The Rolling Life

    The problems just started a week ago, and the main issues are:
    - page load time is very inconsistent: according the GTMetrix.com, my page load time was around 2 sec. Now is varies every time between 4sec and 120(!!!!!) sec
    - CSS seems to load as latest, so my layout looks very strange at first and then flashes into the right look at the latest.
    - Site goes offline for no reason every now and then (and my crappy host bluehost keeps telling me it's not their fault)

    I tried to deactivate all the plugins I'm using and activate them 1 by 1 again to see what plugin or plugin combination causes this (my usual way of troubleshooting :-)) But this doesn't seem to work this time...
    Deactivating all plugins doesn't really help at all.
    My guess is that i did something wrong with the settings of W3 Total Cache (and Cloudflare CDN) but I have too limited knoweledge to discover what.

    Is there anyone out there who cares to take a look at y site and help me out here??
    I will be forever grateful :)

    Thanks
    siegmich

  2. mikeotgaar
    Member
    Posted 2 years ago #

    A cursory inspection shows the following:

    Cloudflare hosted files are loading slowly (I'm seeing times like 2.5 seconds). Disable the CDN and see if that helps.

    It doesn't look like you've enabled cache pre-load, or pre-load isn't working. Time to first byte served for un-cached pages is also very slow - I got between 7.5 seconds and 15 seconds.

    The problems just started a week ago

    Which version of the plugin are you running now, and which were you using before the problem started? I'd try reverting to the last version used when your site was OK, or to W3TC v 0.9.2.3 (which is the last version I've found where the pre-load function works reliably)

    Other issues
    Google maps API is included twice; not recommended but shouldn't impact the site performance so much.

    Images loaded from imgcdn.nrelate.com show average load time of over 1 second. None of them are large
    Similarly, images served from:
    worldnomads.com, distilleryimage5.s3.amazonaws.com

    Lastly, images from your own site show a high latency.
    (Maybe use Jetpack Photon to serve images from WordPress.com instead)

    This file is not found: http://www.google.com/latitude/apps/badge/api?type=photo&photo=bhqA0jwBAAA.WWKO4DVjk7fIm73lImrpdg.mwIpL4CzLoLXMY49pK2fgw and takes a long time to time-out.

    Hosting: Doesn't look great, but even un-cached the site should perform better than it is. Check your server resource logs for CPU and memory utilization. Something may be running CPU at limits too often. The first post I tried to load timed out - often an indication of resource limits.
    PS. I'm not going to plug for any hosting service here!

  3. siegmich
    Member
    Posted 2 years ago #

    Hi @mikeotgaar!

    Thanks for your cursory inspection, for me thats quit useful and very kind to get professional insights as I'm just a WP beginner. Thanks for your time!

    The reason I signed up for Cloudflare was to get faster and more reliable service for worldwide visitors (as my site's audience comes from all corners of the world)

    I disabled my Cloudflare account for both my sites, but run into a fatal error for 1 of them.
    My other site Korbin Photography is getting even faster after I disable Cloudflare (under 1sec load time and PageSpeed of 97%) but the website I posted here to solve this one completely crashed after disabling Cloudflare. I get a 'DNS Resolution Error' and can not even login to my wp-admin....

    If I activate Cloudflare again the problem is solved, but not really helpful as I want to deactivate the service...

    Any tips? thanks!

  4. mikeotgaar
    Member
    Posted 2 years ago #

    Sounds like a .htaccess error.
    Use your site file manager (Bluehost uses CPanel to the best of my knowledge)to edit the root folder .htacces file.

    Delete everything AFTER the first mention of # BEGIN W3TC and the last line of W3TC - END W3TC .... (Last line is probably just before # BEGIN WordPress

    That should allow you to log in to your site again... IF NOT, then rename the .htaccess file to something like .htacces.BAK. You then just need to reset your permalinks in WP admin.

    SUGGESTION: Rename or delete W3TC plugin Folder as well, and re-install a fresh copy once you back in.

    If you still have problems, I'd be happy to help out - let me know and I'll post a contact form link

    There are several threads about Cloudflare in the plugin forum...

  5. siegmich
    Member
    Posted 2 years ago #

    hi,
    my .htaccess file doesn't seem to be the way its meant to be...
    the only content of it is as follows:

    ## EXPIRES CACHING ##
    
    ExpiresActive On
    ExpiresByType image/jpg "access plus 1 year"
    ExpiresByType image/jpeg "access plus 1 year"
    ExpiresByType image/gif "access plus 1 year"
    ExpiresByType image/png "access plus 1 year"
    ExpiresByType text/css "access plus 1 month"
    ExpiresByType application/pdf "access plus 1 month"
    ExpiresByType text/x-javascript "access plus 1 month"
    ExpiresByType application/x-shockwave-flash "access plus 1 month"
    ExpiresByType image/x-icon "access plus 1 year"
    ExpiresDefault "access plus 2 months"
    
    ## EXPIRES CACHING ##
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    really feel like a complete idiot now... :)

  6. mikeotgaar
    Member
    Posted 2 years ago #

    1.Try deleting all
    ## EXPIRES CACHING ## all text ## EXPIRES CACHING ## Leaving only the WordPress stuff in...
    2.And do rename/delete W3TC
    3.Look for this folder ROOT/wp-content/W3TC and delete it.
    4. Clear browser cache (everything from beginning of time)
    Still having a problem, then rename/delete the .htaccess file and let WordPress re-generate it when you set the permalinks

    That should get you back into your site admin - 99.99% of time

    Once you've done all those steps, and if you still get DNS error, then it's over to your hosting support

    Don't feel like an idiot - it's a good learning experience
    W3TC isn't the easiest caching system to set-up...

  7. siegmich
    Member
    Posted 2 years ago #

    hi Mike,
    I followed your steps, but without the desired result..
    could you do me a favor and have a look before I contact my host?
    email me at: sieghart.michielsen(at)gmail(dot)com and I'll send you FTP details!
    thanks!

  8. mikeotgaar
    Member
    Posted 2 years ago #

    Mail address sent...

Topic Closed

This topic has been closed to new replies.

About this Topic