Support » Plugin: Site Kit by Google » site kit Stuck at “Checking compatibility

  • Resolved tawfeqakas

    (@tawfeqakas)


    After installing and activating Site Kit setup a user is stuck at the “Checking compatibility” stage. The “Start setup” button doesn’t appear.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 23 total)
  • Same problem with me. i installed site kit but then i activated clodflare flexible SSL site kit started endless loop so google services no longer appeared in dashboard i tried to reinstall several times and now it says checking compatiblity.

    • This reply was modified 8 months, 1 week ago by Est1Cem4G.

    anybody knows when the update of plugin is available? i hope they fix it all.

    Plugin Support James Osborne

    (@jamesosborne)

    @tawfeqakas Sorry to hear you’ve been encountering issues during setup. There are some troubleshooting steps on the plugins website which you can try if not already attempted.

    If the issue remains after following those steps please share your Site Health information and we can troubleshoot further

    @levanii Thanks for the input. If you’d like to create a new support topic and share your Site Health information we’d be happy to look into your issue specifically, there may be differing reasons for encountering this issue.

    @jamesosborne i tried everything, it is still says “checking compatibility”.
    please find below my site health info.

    
    ### wp-core ###
    
    version: 5.4.1
    site_language: en_US
    user_language: en_US
    timezone: +00:00
    permalink: /index.php/%year%/%monthnum%/%day%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/gulfcent/public_html/wp
    wordpress_size: 39.44 MB (41355577 bytes)
    uploads_path: /home/gulfcent/public_html/wp/wp-content/uploads
    uploads_size: 142.14 MB (149047754 bytes)
    themes_path: /home/gulfcent/public_html/wp/wp-content/themes
    themes_size: 30.83 MB (32328933 bytes)
    plugins_path: /home/gulfcent/public_html/wp/wp-content/plugins
    plugins_size: 112.38 MB (117834574 bytes)
    database_size: 10.11 MB (10598880 bytes)
    total_size: 334.90 MB (351165718 bytes)
    
    ### wp-active-theme ###
    
    name: Porto Child (porto-child)
    version: 1.1
    author: P-THEMES
    author_website: https://www.portotheme.com/
    parent_theme: Porto (porto)
    theme_features: post-thumbnails, title-tag, editor-style, automatic-feed-links, woocommerce, menus, post-formats, html5, wp-block-styles, responsive-embeds, align-wide, editor-styles, editor-color-palette, widgets
    theme_path: /home/gulfcent/public_html/wp/wp-content/themes/porto-child
    
    ### wp-parent-theme ###
    
    name: Porto (porto)
    version: 5.3.1
    author: P-THEMES
    author_website: http://www.portotheme.com/
    theme_path: /home/gulfcent/public_html/wp/wp-content/themes/porto
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.2, author: the WordPress team
    
    ### wp-plugins-active (11) ###
    
    Contact Form 7: version: 5.1.7, author: Takayuki Miyoshi
    Duplicate Post: version: 3.2.4, author: Enrico Battocchi
    Dynamic Featured Image: version: 3.7.0, author: Ankit Pokhrel
    Elementor: version: 2.9.8, author: Elementor.com
    Elementor Pro: version: 2.9.4, author: Elementor.com
    Porto Theme - Functionality: version: 1.6.1, author: P-Themes
    Site Kit by Google: version: 1.8.0, author: Google
    Slider Revolution: version: 6.2.6, author: ThemePunch
    WooCommerce: version: 4.1.0, author: Automattic
    WP-Live Chat by 3CX: version: 8.1.7, author: 3CX
    WPBakery Page Builder: version: 6.2.0, author: Michael M - WPBakery.com
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-962.3.2.lve1.5.26.9.el7.x86_64 x86_64
    httpd_software: LiteSpeed
    php_version: 7.3.17 64bit
    php_sapi: litespeed
    max_input_variables: 3000
    time_limit: 1000
    memory_limit: 256M
    max_input_time: 1000
    upload_max_size: 32M
    php_post_max_size: 32M
    curl_version: 7.69.1 OpenSSL/1.1.1g
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.29-cll-lve
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/gulfcent/public_html/wp/wp-content
    WP_PLUGIN_DIR: /home/gulfcent/public_html/wp/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### google-site-kit ###
    
    version: 1.8.0
    php_version: 7.3.17
    wp_version: 5.4.1
    reference_url: https://www.gulfcenter.co/wp
    amp_mode: no
    site_status: not-connected
    user_status: not authenticated
    active_modules: site-verification, search-console
    required_scopes: 
    	openid: ⭕
    	https://www.googleapis.com/auth/userinfo.profile: ⭕
    	https://www.googleapis.com/auth/userinfo.email: ⭕
    	https://www.googleapis.com/auth/siteverification: ⭕
    	https://www.googleapis.com/auth/webmasters: ⭕
    search_console_property: none
    
    
    Plugin Support Renee Johnson

    (@reneesoffice)

    @tawfeqakas thanks for the details! When checking your site, it does not appear fully secure with mixed content warnings.

    I’m not sure if this is directly causing this issue, but Site Kit relies on your how your site is defined in the WordPress settings as well as where your site is currently available to add it to the service.

    Could you fix those mixed content assets (they appear to be images served over http://) and attempt setting up Site Kit in an incognito browser?

    Let us know if that helps!

    @reneesoffice Thanks renee, i fixed the mixed content issue.

    re-installed the plugin in an incognito tab,
    unfortunately.. still having the same issue. “checking compatibility”.

    Plugin Support Renee Johnson

    (@reneesoffice)

    @tawfeqakas thanks for reporting back. We may need to check with the team about your case. In the meantime, could you attempt this workaround which has helped some users:

    1) From the WordPress dashboard under Settings > General, could you change the WordPress address and the Site address from https:// to http://. You may be logged out and prompted to log back in to your site. These are the settings.

    2) Return to the settings, change the values back from http:// to https:// again.

    3) Reset Site Kit and attempt the setup process again.

    Thank you!

    thank you @reneesoffice

    I tried that already. it is not working. still showing “checking compatibility” message.
    your support is highly appreciated.

    Plugin Support James Osborne

    (@jamesosborne)

    @tawfeqakas Many thanks for providing an update. Can you please follow the steps below and inform me whether you’re able to proceed with Site Kit setup?
    1. Reset Site Kit
    2. Access Search Console, select the respective property and remove it (Settings > Remove Property).
    3. Access your site from a browser incognito window
    4. Attempt Site Kit setup once more

    Let me know if the above works, if not we can test the same setup environment as your own while also checking with the team internally. To do so please also provide your current hosting provider.

    i removed property from search console and added only domain without prefix. then i verified it. and tried activate site kit, but is’t stuck on “checking compatibility”
    (i also removed site from adsense and google analytics).
    error i get while setting up site kit: https://i.imgur.com/aTVJlEC.png

    • This reply was modified 8 months, 1 week ago by Est1Cem4G.
    Plugin Support James Osborne

    (@jamesosborne)

    @levanii Thanks for keeping an eye on this thread, the problem seems similar. I’ll respond to you within your own support topic if thats ok. We can troubleshoot from there.

    @jamesosborne thank you, still not working.

    Plugin Support James Osborne

    (@jamesosborne)

    @tawfeqakas Thanks for the update. While we’re still investigating this issue one user with a similar setup was able to successfully connect using an alternate solution.

    I’ll keep you posted here with any additional information.

    tawfeqakas

    (@tawfeqakas)

    @jamesosborne yes i checked that post. i dont have any SSL activated.

    Plugin Support Renee Johnson

    (@reneesoffice)

    @tawfeqakas thanks for the info. We’ve checked on our side, and it seems something in your environment is blocking Site Kit from proceeding.

    1) We’ve seen this occur in cases where there are mixed content warnings in the admin.

    On the page where Site Kit is trying to check compatibility, could you check for any browser console messages?

    2) Could you tell us which method you are using to serve the site over SSL? The site is only available over https:/// SSL from the front end.

    Perhaps providing the values in your WordPress Settings under Settings > General would give more insight too.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘site kit Stuck at “Checking compatibility’ is closed to new replies.