Support » Fixing WordPress » Site keeps redirecting to install.php over and over again

  • Resolved nareshrawat0101

    (@nareshrawat0101)


    my website keeps redirecting to http://www.nepalconstructionmart.com/wp-admin/install.php automatically over and over again. Any help would be thankful. Actually it happens while updating or publishing products or if i open more than 15 tabs of my site from backend. Once the site goes to install.php then after 4-5 minutes it starts working fine. I already tried to repair the mysql database tables. And it shows following error

    Problems with indexes of table wp_xbau_woocommerce_shipping_zone_locations
    PRIMARY and INDEX keys should not both be set for column location_id
    More than one INDEX key was created for column location_type
    Problems with indexes of table wp_xbau_woocommerce_tax_rate_locations
    More than one INDEX key was created for column location_type

    https://wordpress.org/plugins/wordpress/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Michael

    (@michaelvdberg)

    Your website works great from my site. I didn’t got any redirect to the install page. When I visit your first like I got the message: “WordPress is already installed”.

    Please clean your browser cache of your browser and try it again!

    Thread Starter nareshrawat0101

    (@nareshrawat0101)

    hello thanks for your reply, yes you are right the site working properly every time however sometimes only when three or more people simultaneously insert or update the data from the wp-admin then some thing went wrong and site goes to install.php. And after few minutes like 4-5 again, the site starts working fine. This problem i have been facing form last 3 months and i didn’t get any solutions yet.

    Michael

    (@michaelvdberg)

    Maybe you can delete the other users and add them again to your website? Or you can upload the wordpress core files again to your server. Don’t copy the wp-config.php and wp-config-sample.php. You can add this core files for example by FileZilla or by another FTP client.

    Please be sure you have a back-up before you do something.

    I’m having this exact same problem.
    Randomly my site redirects to “install”, then after some time it’s back up running and everything works except all the links on the site! Then if I go to “permalinks” and save, the links work again.

    Did you solve the problem?

    Thread Starter nareshrawat0101

    (@nareshrawat0101)

    Hey Trunejuel, yes now its working fine with one or two user, however with 4 or more than 4 users publishing and updating products simultaneously the site goes down.

    i am experiencing the same problem with my site… WordPress only redirects to install.php when it can not find a database. this missing database issue usually occurs because i have crappy host, ipage , they limited the mysql query string to 75k per hour and once that max usage is optimised, the site and every other WordPress site on that ipage user account starts redirecting to install.php

    A way to combat this is to cache the mysql query string (but ipage has refused to do that – instead they have offered to increase the MySQL query limit to 150k queries per hour for an extra $36 and this will still not be sufficient for a busy site, especially during content upload or peak periods).

    @nareshrawat0101 i noticed your host is ipage also. all ipage blogs not on their VPS plan will eventually suffer the same fate as more and more load is added to the site. it is sad… but thats wha it is… ipage sucks for this sole reason!

    Thread Starter nareshrawat0101

    (@nareshrawat0101)

    yes oweibor that’s the exact problem with ipage shared hosting. Thanks

    My website http://onlinejuction.net is redirecting me to http://onlinejuction.net/wp-admin/install.php whereas I didn’t made any change. After having issue, I checked .htaccess & wp-config.php and everything seems ok. So I replaced wp script with new one except wp-content and wp.config.php but problem not solved. Please help me!

    • This reply was modified 4 years, 4 months ago by bikasgurung. Reason: typic mistake

    @bikasgurung ask your host to increase your SQL query limit. Blogs hosted with nepallink, ipage and a few others are most likely to experience this error. They have some very weird database server settings

    • This reply was modified 4 years, 4 months ago by oweibor.

    I’m with Fatcow and the query limit was my problem in case anyone else has this problem.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Site keeps redirecting to install.php over and over again’ is closed to new replies.