Support » Plugin: Yoast SEO » Site keeps crushing with YOAST SEO

  • Resolved Lilumi Odi

    (@lilumi)


    In logs I see this:

    KILLED QUERY (36545 characters long generated in /wp-content/plugins/wordpress-seo/lib/orm.php:286): SELECT * FROM wp_yoast_indexable WHERE id IN (‘1’, ‘2’….

    My site have 10000+ posts so, YOAST SEO should split such queries into chunks!
    Please do this and release a fix asap!

    • This topic was modified 4 months, 3 weeks ago by Lilumi Odi.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Maybellyne

    (@maybellyne)

    Hello Lilum,

    Can you confirm your server has all the right requirements? If you are not sure, speak to your host provider. They may need to increase the PHP memory. This guide explains more: https://kb.yoast.com/kb/plugin-requirements/

    Thread Starter Lilumi Odi

    (@lilumi)

    Yes, I confirm that my server has all the right requirements:
    Wordpress 5.7.2
    PHP version 7.3
    PHP memory 1024M
    MySQL 5.7.34-37
    Curl 7.58.0
    OpenSSL/1.1.1

    @maybellyne please look carefully to my request!
    Error is with the limit of mysql query!

    KILLED QUERY (36545 characters long …

    Yoast seo plugin generates a very long SELECT quesry in MySQL and for cases when there are a lot of posts on the site (in my case I have 10000+ posts) it causes a crash.

    This query should be split into chunks!

    • This reply was modified 4 months, 3 weeks ago by Lilumi Odi.
    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Thanks for your clarification, @lilumi. We are sorry to hear that Yoast SEO is exceeding the maximum limit of your MySQL server due to a long SELECT query where you have 10K+ items on your site.

    The issue you’re currently experiencing here typically occurs when the SEO data optimization hasn’t been performed. Can you please confirm whether you’ve performed the SEO data optimization from the SEO → Tools page on your site dashboard?

    If not, please perform the relevant analysis first to see whether this improves anything (it should).

    Thread Starter Lilumi Odi

    (@lilumi)

    @mazedulislamkhan I waited for the SEO data optimization for 13 hours, but it still didn’t finish and in dev tools XHR response always shows the same values: https://www.dropbox.com/s/624zlz71chxnymz/Screenshot%202021-07-09%20002309.png?dl=0

    Meanwhile I received 978 messages about killed query in the last 15 minutes!!!! :
    KILLED QUERY (1524917 characters long generated in /wp-content/plugins/wordpress-seo/lib/orm.php:286): SELECT * FROM wp_yoast_indexable WHERE id IN (‘1’, ‘2’, ‘3’, ‘4’, ‘7’, ‘9’, ’12’…

    Please make a fix for this!

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @lilumi

    Were you able to check if the SEO data optimization was able to complete and if this helped with the query issues in the database?

    We do know that for larger sites, we would recommend running the indexables process via WP-CLI. Could you check if you are able to run it through WP-CLI and complete the process and see if this helps resolve the issue – https://developer.yoast.com/features/wp-cli/reindex-indexables/

    Thread Starter Lilumi Odi

    (@lilumi)

    @mikes41720 I did SEO data optimization using WP-CLI (took 88 minutes) but error message still exists: KILLED QUERY (1524937 characters long generated in /wp-content/plugins/wordpress-seo/lib/orm.php:286): SELECT * FROM 'wp_yoast_indexable' WHERE 'id' IN ('1', '2', '3', '4', '7', '9'

    • This reply was modified 4 months, 2 weeks ago by Lilumi Odi.
    Plugin Support Michael Tina

    (@mikes41720)

    Hi @lilumi

    You’ve mentioned that you’ve already met the necessary plugin requirements here and that you’ve tried to reset the indexables and re-run it via WP-CLI and that you’ve completed the process, and you’re still encountering the error message related to the killed query.

    If this still occurs with your website on WordPress 5.7.2, a default WP theme such as TwentyTwenty, and only Yoast SEO v16.6.1 as the only plugin enabled (conflict check instructions here), we suspect this to be a bug. Please do log a bug report here so our developers can check and provide feedback on this further – https://yoast.com/help/how-to-write-a-good-bug-report/

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

    Thread Starter Lilumi Odi

    (@lilumi)

    I completelly dissagree with marking it as “Resolve”.

    @devnihil I can make an activity here if you wish: what the status of the bug? Was it fixed? When it will be released to public?

    I updated a plugin to a version 16.7 but the issue still exists.
    I checked your github and saw that I’m not alone with this problem and there are few opened issues related to this bug.

    How often do you want me to ping here to keep this thread active?

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.