Support » Fixing WordPress » Site just went bonkers

Viewing 15 replies - 1 through 15 (of 25 total)
  • try restarting mysql and apache. This has happened to me before and I had to do a whole system reboot to fix.

    this server isn’t sitting under my desk. it is hosted elsewhere.

    Moderator James Huff

    (@macmanx)

    Ask your host if they changed anything.

    Well, the odd thing is that my refer and shortstat tables are in the same database, and they are both working fine.

    Did _you_ change anything recently? Add any new plugins or anything? The SQL is all screwed up. In looking at the errors generated, it looks like the code that creates the SQL may have been altered. PostIDs that are supposed to be part of the queries are not there.
    Tg

    The only thing I changed was this morning, I added htaccess to my refer directory. I didn’t touch anything in my WordPress files. I made a post last night about the Firefox NYTimes ad, and it seemed to be working fine (checked the site after the post, and it was there).

    I looked in my database, and noticed that all of my posts had a category setting of “0”. Shouldn’t they have the ID of the category as that value? At least “1” if nothing higher?

    no the category gets set in the post2cat table. each post id should have a category id associated with it in that table.

    i’m having a problem that might be related: when i use the nightlies or whatever, my blog url is getting changed from /wordpress to /cgi-system. i’m on dreamhost, which runs cgi-php as the default, and i’ve tried a bunch of stuff. it seems that when i try to log in, my blog url gets changed. any ideas?

    gotcha…all those values are intact.
    I can see the post that I made last night, so whatever happened had to have been around then.
    When I go to my WP admin page, all the menu items across the top say “Array”, except for View Site and Logout.

    kcomphlint – try undoing you the .htaccess you did and see if the problem goes away. If so, then there might be aconflict going on in there that’s causing the settings to be cleared out.
    Tg

    My problem has been solved, thanks to BigJibby. You need to add this line to the top of your wp-config file:
    $_SERVER[‘SCRIPT_NAME’] = $_SERVER[‘SCRIPT_URL’];
    Put that right above where it says:
    // ** MySQL settings ** //
    And you’re all set, I guess.
    Read more about it?
    https://panel.dreamhost.com/kbase/?area=2933

    I guess you can also choose not to run php-cgi. In Dreamhost, you do this by going to Domains -> Web -> Edit.

    Tried trevorturk’s suggestion, but that didn’t work either.

    I think there is a problem with the 12/16 nightly, if that’s what you’re using

Viewing 15 replies - 1 through 15 (of 25 total)
  • You must be logged in to reply to this topic.