Support » Plugin: Really Simple SSL » Site is Redirect to Admin-area

  • Resolved militarium

    (@militarium)


    Hello. i upated your plugin to latedt version and when i enter on the site – video.militarium.ge – this iste is redirect to wp-admin area.
    How to fix it?
    I disabled this plugin – fixed – but i wnat to continue using this plugin so please help me as soon as possible.
    Cheers

Viewing 15 replies - 1 through 15 (of 20 total)
  • or if it possible, please send me Old version – it was perfect.
    So, my site is VIDEO.MILITARIUM.GE – you can see, that when you enter on the site – it will be redirec to /wp-login page.
    Help me

    @militarium yes even I am facing similar problem, till then if you want you may download the previous version here

    https://downloads.wordpress.org/plugin/really-simple-ssl.2.5.13.zip

    @nit233 thanks a lot.
    Please tell me, where is placed plugin’s old version, if i want to downgrade any plugin?
    Cheers.

    I found it. Thanks.
    Well, i hope, plugin’s admin will comment asap and we will fix our problem.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi, strange, I haven’t been able to reproduce it yet.

    could you try replacing in class-front-end.php, in the function wp_redirect_to_ssl()

    This line:
    $redirect_url = set_url_scheme( esc_url_raw( $_SERVER['HTTP_HOST'] . $_SERVER['REQUEST_URI'] ), 'https' );

    With this line:
    $redirect_url = "https://" . $_SERVER['HTTP_HOST'] . $_SERVER['REQUEST_URI'];

    A quick way to test would be to disable the setting “wp redirect” in settings/ssl. If that solves the issue, replacing above lines might help.

    Hi there.
    Well, i unchecked “Enable WordPress 301 redirection to SSL” – fixed, BUT after this i MUST add this code and then Reenable 301 redirection?
    Is it right?

    There is some major difference between the latest and v.13?
    I’m not programmer – better for me old version.

    Please tell us, or can you update this plugin to v.15?

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    The redirect was changed, I’ll update it to 2.5.15 today.

    I have committed on github,
    https://github.com/rlankhorst/really-simple-ssl

    Only class-front-end.php has changed, so you only have to replace this file. If you could check if if this fixes your issue, that would be great!

    okay, i will wait update in my worpdress plugin area.
    Thanks a lot for quick response.

    P.S. amazing plugun!

    I dowloaded from Github v.15 and please wait, i will reply you, if in this version Fixed current issue.

    cheers.

    Hell. i checked v.15 and there is the same problem – i’m very sorry 🙁
    Well, mayve old version v.13 will be OK for me.

    So there is going to be an update today? Because I have a similar problem: when entering the non www version, domain.be, it redirects to my wp-admin instead of my homepage. Before the update it worked fine

    Yes, v.14 has this problem.
    Well, guys, i downgraded to v.13 and everything is OK.
    V.15 tested and there is similar problem – maybe admin must add/edit some code before realase v.15 on WordPress Store.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    So maybe the problem is the function “wp_safe_redirect”.

    I have currently committed the plugin with wp_redirect. Please check if this helps for your issue.

    Again, it is only the class-front-end.php that has been changed.

    Yes, i downloaded from Github and uploaded to my site. There was similar problem – redirection. Why i downgraded v.15 to v.13.

    (This is the best SSL plugin ever ever ever)

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    P.S: I’ve committed to github: github.com/rlankhorst/really-simple-ssl

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Site is Redirect to Admin-area’ is closed to new replies.