Support » Plugin: Glance That » site is experiencing technical difficulties

  • Hey, Typewheel!
    I had your plugin in use on my site about 1-2 yrs ago and deleted it for some now unrecalled reason. I decided to add it on again but am having this problem… After an install and activation, in the normal At a Glance box on the Admin page I get only this message: “The site is experiencing technical difficulties. Please check your site admin email inbox for instructions” and the remainder of the Admin page stops loading.

    No email is sent (spam box also checked) and I can only stop this by deactivating your plugin and refreshing the Admin page. I have ALL other plugins and WP itself updated as of the v5.2 upgrade. Any help would be appreciated.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author uamv

    (@uamv)

    This is the message WordPress now displays when a PHP Fatal Error is thrown. It should send notice to the administrator email shown in Settings > General.

    Since you’re not receiving the email from WP, could you check the server logs and grab the entry that relates to this issue? I’m very curious to know why this might be happening.

    I suppose one other first step you could take to try and remedy this is to manually remove any entries from your database _usermeta and _options table that contain glance_that. I don’t anticipate this would cause any problem, but worth a try. It sounds more like there might be some conflict with another plugin or Glance That is using some PHP feature that may not be supported in the version of PHP you’re running.

    Let me know if you’re able to grab something from that log. Thanks!

    Plugin Author uamv

    (@uamv)

    You might also want to install Plugin Detective to quickly see whether it may be a conflict with another plugin. When you run the investigation, add Glance That as a required plugin. However, not sure how this will work if you’re encountering a fatal error.

    OK, @uamv, sorry if this seems long… 🙂

    Thanks for your suggestions so far! I downloaded and reinstalled “Glance That” again this morning to get a fresh look at the error.

    1)

    I suppose one other first step you could take to try and remedy this is to manually remove any entries from your database _usermeta and _options table that contain glance_that.

    I’m assuming I do this after I have completely uninstalled ” Glance That” first? I have _not_ tried this yet. Please confirm.

    2) I re-checked and confirmed the email used for “administrator email shown in Settings > General” and looked again for the message in that account including the spam file – no notice.

    3) In the Error Log the only recent items where today and the date corresponding to the last time I tried to install and activate the plugin. These are are below:

    [10-May-2019 15:00:21 UTC] PHP Fatal error: Cannot redeclare plugins_api() (previously declared in /home1/mysite/public_html/pigcity7/wp-admin/includes/plugin-install.php:101) in /home1/mysite/public_html/pigcity7/wp-admin/includes/plugin-install.php on line 230

    [10-May-2019 15:01:36 UTC] PHP Fatal error: Cannot redeclare plugins_api() (previously declared in /home1/mysite/public_html/pigcity7/wp-admin/includes/plugin-install.php:101) in /home1/mysite/public_html/pigcity7/wp-admin/includes/plugin-install.php on line 230

    [12-May-2019 10:22:10 UTC] PHP Fatal error: Cannot redeclare plugins_api() (previously declared in /home1/mysite/public_html/pigcity7/wp-admin/includes/plugin-install.php:101) in /home1/mysite/public_html/pigcity7/wp-admin/includes/plugin-install.php on line 230

    [12-May-2019 10:22:10 UTC] PHP Fatal error: Cannot redeclare plugins_api() (previously declared in /home1/mysite/public_html/pigcity7/wp-admin/includes/plugin-install.php:101) in /home1/mysite/public_html/pigcity7/wp-admin/includes/plugin-install.php on line 230

    I suspect that is a standard WP file, but I opened that file mentioned and here is a link to a .JPG of my editor with that section of the file’s code:
    https://www.porkopolis.org/download/errorlog-line230.jpg

    I also ran the “PHP Compatibility Checker” plugin and received no warnings.

    Then I ran your suggested ” Plugin Detective” which when activated only gave me a white screen and another plugin issue I probably don’t have time to address right now… Sorry.

    Also, here is some info from my shared server in case it is helpful:
    Versions
    cPanel 78.0 (build 21)
    Apache 2.4.39
    PHP 7.0.33
    MySQL 5.6.41-84.1
    Perl 5.28.0

    Thanks for your help so far! I’ll follow your next suggestions…
    DANO

    Plugin Author uamv

    (@uamv)

    That’s helpful. I already have an idea of what might be the issue. Could you go to Tools > Site Health on your site and provide me with a list of other active plugins so I could try and reproduce? If my inkling proves true, I’ll try to get a fix out sometime this week. Thanks! If you’d rather not post the list of plugins here, you could drop them in my contact form at typewheel.xyz/contact/. Thanks! Hope we can sort this!

    Plugin Author uamv

    (@uamv)

    @porkopolis Version 4.6 should now work well for you. Update and let me know if all is resolved.

    Hey, @uamv, Today I deactivated and deleted Glance That then followed your earlier suggestion:

    I suppose one other first step you could take to try and remedy this is to manually remove any entries from your database _usermeta and _options table that contain glance_that.

    I found 6 entries in _usermeta and two more in _options and deleted them all. Then I reinstalled your updated version. Everything is working terrific now! Thank you for all your help and your quick replies to my requests.

    DANO

    Plugin Author uamv

    (@uamv)

    Awesome! Great to hear that we’ve got it resolved! I hope it continues to serve you well.

    The solution is very easy:

    In PHP.INI

    memory_limit -1

    @claudiac2019, Thanks for your solution. It’s work for me. 😉

    Plugin Author uamv

    (@uamv)

    Please note, the solution mentioned here which involves modifying your php.ini file is not a solution for the issue mentioned in the original post. Also note that allowing your site unlimited use of your server’s memory is not advisable.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘site is experiencing technical difficulties’ is closed to new replies.