Support » Plugin: Super Page Cache for Cloudflare » site is crashed and cloudways shows high CPU and memory cnsumption

  • Resolved Zakir Sajib

    (@zakirstage)


    site is crashed and cloudways shows high CPU and memory consumption after I activate the plugin.

    I had to deactivate the plugin and now everything cools down.

    The new version causing this issue? It wasn’t like this before.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @zakirstage,
    This is very unusual as @salvatorefresta has many cloudways server and we test the plugin thoroughly before releasing. It is being used in many cloudways server without ever having this issue. The plugin is quite light with very little resource usage. The entire plugin was designed keeping performance in mind. I think something else might be causing the issue. I think you should talk to cloudways to track down what was eating the resources.

    Just a few note, inside the fallback cache, were you using cURL mode?
    Also, were you preloading a lot of URLs at a go?
    The reason I ask this is that all of these operations use cURL which can take a little resource to execute. Besides, there is nothing many resources intensive.

    @salvatorefresta do you got any ideas?

    Thread Starter Zakir Sajib

    (@zakirstage)

    No I wasn’t use cURL method. I just put the api key of CF and then enabling page caching and then it starts.

    What I noticed, after I activated the plugin, whole site getting slower, and then I logged in to Cloudways and checking the our site status.
    Ram increased 7 out of 8GB
    CPU 70% and then 80% out of 100% and went to 100% and then I couldn’t access mysql, phpmyadmin. The error message in front-end: Error to establishing database connection.

    Our usual CPU 7% and RAM 3.62 out of 8GB.

    It was never like that as we don’t have literally no traffic.

    Then I renamed the plugin via FTP and deelted the one folder that plugin created in wp-content and remove the rules in htaccess file that plugin created. After few minutes to wait i can see CPU, RAM was cooling dow and then I deleted the plugin and deleted the plugin options fields from database.

    Now everything is fine.

    Same thing happened in december and I talked to Cloudways support, they didn’t exactly identified which plugin as new relic was not enabled in cloudways. That time i had to rename the plugin folder and then i had to create another plugin folder and move all plugins and gradually enabling them one by one. And all restored.

    Today I thought lets install your plugin and then it start causing this issue.

    Regarding preloader, I didnt have the chance to change anything as I was not able to access as CPU went high.

    Guys I need your plugin. Is there any way you can help us? I can share the login details of everything (WP, Cloudways, Cloudflare).

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @zakirstage ,
    you should enable the log mode in high verbosity. If something triggers the cache purging may times at once, you can see it into the log file.

    Thread Starter Zakir Sajib

    (@zakirstage)

    I am closing it as I believe this is specific to my particular site. but we have another site where it does not have this type of issue.

    Thank You guys.

    chacha2340

    (@chacha2340)

    @zakirstage Hello ! I’ve had the same issue (cloud ways hosting) but not with this plugin.

    I’m getting mad as this is a fresh new install and I’ve tried to install new ones 3 times…

    Cloudway’s support is not helpful, they say it’s fixed but I’m still getting the database error and high CPU usage 1 time over 5, so I can’t work on the website and do anything in these conditions.

    I’m pretty sure this is a hosting / server problem, but I’m designer and can’t really spot it despite more than 1 day looking for a solution, and support doesn’t seems to be keen to help me out….

    Did you do anything else in particular ? How did you get things back to normal ?

    Thanks;

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hey @chacha2340,
    I think you should use a better hosting. I can highly recommend you to try BigScoots. They are the best hosting provider I’ve used. I’ve ben using them for more than 6-7 years now and have zero complaints. Their support is the best you can think of. There is no affiliate links or anything, but I thought I should share my suggestion, the rest is up to you. 🙂

    Thread Starter Zakir Sajib

    (@zakirstage)

    @chacha2340

    Its nothing to do with cloudways in 99% case. Though I agree with you about their customer support. They are not up to the mark.

    Check your theme and the plugins. in most cases, it happens wp admin-ajax request.

    My issues were several. I enabled preload mode of this plugin and it generates preloading of all our pages(100 pages), products(3000 items), posts etc and it loads the server cpu and memory. So i disabled preload option. I had another issue with wp cron, it was doing some weird cron jobs frequently and it loads server databases, cpu and memory. I had a chat plugin which was loading on each page of the frontend of the site and it affects on server too.

    so I had to take care of these 3 stuffs and now it’s fine.

    Later I understood it’s nothing to do with Cloudflare plugin.

    So you need to find out the exact reason. Most probably adamin ajax request.

    Thread Starter Zakir Sajib

    (@zakirstage)

    @isaumya Do you have any plan to add support for wp optimize premium plugin? Currently, your plugin only supports the free version of wp optimize (https://wordpress.org/plugins/wp-optimize/) plugin?

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @zakirstage,
    I don’t think any changes needs to be made on the plugin. If you use WP Optimize paid version and enable the settings in the third party tab, it should just work. Have you tried it?

    Thread Starter Zakir Sajib

    (@zakirstage)

    I tried before free version and it used to work. For example if I clear cache from your plugin it also clear cache from that plugin.

    but in premium version, it seems your plugin does not even recognise that this plugin even exists. For example, in free version, on thrid party tab, in wp-optimize settings area, it shows message saying: please make sure page caching is not enabled, so i assume your plugin detect the plugin and thats why it showing this message. But in premium version, your plugin does not show any message. So i am bit confused.

    ofcourse when i use your plugin, i disabled page caching from that plugin.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @zakirstage,
    Don’t worry about the detection. I will look into the detection, but despite it doesn’t detect the plugin, if you enable the appropriate options for WP Optimize, does it still work with the Paid version of the plugin?

    Thread Starter Zakir Sajib

    (@zakirstage)

    @isaumya Yes Sir.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    So, is it working?

    Thread Starter Zakir Sajib

    (@zakirstage)

    if i clear cache from cloudflare, then wp optimize premium version does not clear cache. I had to manually clear it.

    But it works with free version.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Please note that the way it is supposed to work is that when you purge in WP Optimize, the plugin will also purge the Cloudflare cache. Not the other way around.

    So, try purging cache in the WP Optimize and check if the plugin is also purging the Cloudflare cache or not.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘site is crashed and cloudways shows high CPU and memory cnsumption’ is closed to new replies.