Support » Fixing WordPress » Site indexing problem

  • I am facing an indexing issue here with my self-hosted website on WordPress.
    The website does not appear in the google list using the keywords, not even on the 10th page!
    I checked the URL in Ryte and got the result back that the robots.txt is blocking indexing but have no clue to fix the issue.
    This is the export result of Ryte:

    
    {“status”:”success”,”last_crawled”:”2021-07-17T12:38:19″,”result”:[{“mime”:”text/html”,”count”:1}],”results”:1}
    
    {“status”:”success”,”last_crawled”:”2021-07-17T12:38:19″,”result”:[{“opr”:0.0,”is_indexable”:0,”hash”:13612454157997,”url”:”https://pflegedienst-lilien.de/”,”meta_title”:”Startseite – Ambulanter Pflegedienst Hannover / Altenpflege Krankenpflege”,”header_status”:200,”passes_juice_to_url”:null,”is_local”:1,”mime”:”text/html”,”mime_error”:0,”language”:”de”,”country”:”de”,”robots_allowed_group”:”disallowed”}],”results”:1}
    

    Could I please get some help and guidance on this?
    Thanks in advance.

    • This topic was modified 10 months, 2 weeks ago by Yui. Reason: formatting

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • What do you have under Settings > Reading > Search Engine Visibility ?

    Thread Starter yasaman92

    (@yasaman92)

    That was the first thing I checked and it is unchecked.

    When I look at your robots.txt, it shows Disallow: /
    Perhaps you have a plugin that is affecting that, or you have an actual robots.txt file instead of the dynamic one generated by WordPress.

    Thread Starter yasaman92

    (@yasaman92)

    What is your solution to tackling this issue?
    Unfortunately, I’m not a pro and have no idea how to fix this.

    You can look on your server using FTP or your host control panel File Manager, and see if you have an actual robots.txt file. If so, delete it.
    You can deactivate any plugins that might be affecting robots.txt and then pull up the robots.txt in your browser to see what is generated.

    Thread Starter yasaman92

    (@yasaman92)

    Thank you for your response.
    I have removed the robots.txt from the file manager however, I cannot see my website listed on google using keywords not even on the 6th page.
    In fact, I could spot this thread on the second page using the keywords but not the website itself.
    I still need some help on how to realize which plugins are affecting robots.txt.

    My answer was about two possibilities.
    Since you found an actual robots.txt file, that is the reason that changing the option in WordPress did not do anything. By deleting it, you have started the process of your site being indexed, but the search engines are not instant, so your site won’t magically appear in results.

    If you didn’t create the file, you will still need to discover how it got there, and the likely culprit is a plugin or some other person that worked on your site.
    There is no good way to figure it out. If you can download all your plugins and search their files for the text “robots”, that would narrow it down. Otherwise, you will need to deactivate them, make sure the file is gone, and activate one by one until it shows up again. (It shouldn’t, but it might, be in the theme if you don’t find it in plugins.)

    Thread Starter yasaman92

    (@yasaman92)

    Thank you for your help.
    I have removed the robots.txt from the file manager and my previous issue which was (indexing issue) has been solved however, ever since I deleted the robots.txt the live editor tab is visible on my published website.
    How can I solve this without causing another problem into the page?

    Thanks in advance for the response.

    Thread Starter yasaman92

    (@yasaman92)

    As a result of the above-mentioned issue, there is full access to the admin profile and live editor from the published website.

    I don’t know what you mean by “live editor tab”. Whatever that is, is unrelated to the robots.txt file.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Site indexing problem’ is closed to new replies.