[resolved] Site ID defaulting to 1 (6 posts)

  1. Chris Croome
    Posted 2 years ago #

    I have tried setting the WP-Piwik plugin up with the latest WordPress for a couple of sites and although the "WP-Piwik Settings" "Run test script" returns the correct value for the Site ID in the XML the "Get site configuration details" always returns "1" and the tracking code can't be fetched, the "Tracking code preview":

    <!-- WP-Piwik ERROR: Tracking code not availbale -->

    (Also note the spelling mistake above, s/availbale/available/).

    Trying to view stats results in:

    Piwik error: You can't access this resource as it requires an 'view' access for the website id = 1.

    It might, or might not, be significant that the Piwik site is only available via HTTPS.

    If there is anymore information needed to help debug this problem please let me know.


  2. braekling
    Plugin Author

    Posted 2 years ago #

    Can you tell me more about your configuration details?

    Multisite yes or no? Using WP-Piwik in multisite mode?

    What's about your site URLs? url1.com, url2.com and so on? Or url.com/page1, url.com/page2 and so on?

  3. Chris Croome
    Posted 2 years ago #

    I'm happy to say that it's all working now, I haven't changed anything so I don't know why this is the case, the correct website ID is now being used and the tracking code is correct and stats are also shown.

  4. sjswarts
    Posted 2 years ago #

    Same issue here,

    I have single site, WP-Piwik is running single site mode. 1 URL used, http://www.prolinecontractors.com.au and the test script pulls the right Site ID = 5 but it shows up in the configuration as Site ID = 1

    Help would be very much appreciated


    P.S. Braekling great job mate, highly appreciative

  5. sjswarts
    Posted 2 years ago #

    Here I've added the details:


  6. sjswarts
    Posted 2 years ago #

    Ok this is odd...

    I noticed that the webpage in the test scripts said http://prolinecontractors.com.au but the configuration said http://www.prolinecontractors.com.au

    So I changed Piwik to say http://www.prolinecontractors.com.au instead of without the www and also turned off Auto configuration.

    Saved everything and now it works.

    Something must be a little skew because Piwik says it automatically attributes www subdomain, but maybe it doesn't.

    Anyway it is fixed :)

    Steven Swarts

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-Piwik
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic