Support » Plugin: Surge » Site Health says caching not installed correctly

  • Resolved billbennett

    (@billbennett)


    I deactivated WP Rocket and installed Surge only to get this message.

    caching not installed correctly

    It can’t be the settings 😉

    So what else should I try? Could there be a plug-in conflict?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Konstantin Kovshenin

    (@kovshenin)

    Hey there, thanks for trying out Surge!

    Could you post the full expanded message here? There are a few different reasons why that can happen. Have you tried toggling the Surge plugin off and on after deactivating WP Rocket?

    Konstantin

    Thread Starter billbennett

    (@billbennett)

    That’s pretty much ALL it says.

    The exact words are:

    “Looks like the Surge page caching plugin is not installed correctly. Please try to deactivate and activate it again in the Plugins screen. If that does not help, please visit the WordPress.org support forums.”

    I could send a screen shot, but I don’t think I can paste one here.

    And yes, I deactivated WP Rocket and tried switching off and on a few times. I started turning off plug-ins, but haven’t done the entire set as that can be disruptive.

    Plugin Author Konstantin Kovshenin

    (@kovshenin)

    Thanks for the additional information. That specific message means the automatic installer didn’t work for some reason. The most common cause is a permissions problem to create the wp-content/advanced-cache.php dropin file, and the wp-content/cache/surge directory.

    Would it be possible to check whether these two exist, via FTP/SFTP perhaps? And if they do, if you could tell me the permissions set on them that would be great.

    FYI, WP Rocket deactivation leaves behind an empty file wp-content/advanced-cache.php, similar problem as described here for Surge 1.0.0.

    Plugin Author Konstantin Kovshenin

    (@kovshenin)

    Surge deletes its own advanced-cache.php file on deactivation, this has been fixed in version 1.0.1. Also, during installation, Surge will delete an existing advanced-cache.php anyway, so it’s unlikely that’s the problem.

    during installation, Surge will delete an existing advanced-cache.php anyway

    Surge tries to delete but does not check return code of unlink(), see recommendation in other post.

    Plugin Author Konstantin Kovshenin

    (@kovshenin)

    Thank you for your feedback @ov3rfly.

    @billbennett if you have any further issues please let us know!

    Thread Starter billbennett

    (@billbennett)

    I tried Surge with all other plug-ins deactivated.

    Same problem.

    So I tried it on my staging website:

    https://billb.mystagingwebsite.com/

    And found the same problem.

    So I’m thinking it could be specific to my hosting company: Pressable.

    Does this seem likely?

    @billbennett Your staging site has an active cache system running which obviously comes with Pressable. You might want to contact Pressable support if/how you can disable this if you want to use another cache plugin.

    Thread Starter billbennett

    (@billbennett)

    In that case, it will be the issue with the main site too.

    It’s interesting that online tools like GTMetrix tell me the site is not cached.

    Hi @billbennett 👋 This is Jess from the Pressable Customer Success team. It is true that many caching plugins are not compatible with our system. Particularly if they are trying to make modifications to the advanced-cache.php file which is symlinked. But there are a few caching plugins that are known to work – Nitropack and WPRocket for example.

    Additionally, if you have any concerns about the performance of your site you can feel free to reach out to our team via live chat and we’ll be happy to take a look at your site with you, see if we can recommend any areas for improvement.

    Hello.

    I have the same type of problem. The message is:

    Page caching is not installed correctly
    (Performance)
    Looks like the Surge page caching plugin is not installed correctly. Please try to deactivate and activate it again in the Plugins screen. If that does not help, please visit the WordPress.org support forums.

    Manage your plugins

    advanced-cache.php is created with chmod 644.

    wp-content/cache/surge directory is created with chmod 755.

    wp-content/cache/surge/flags.json.php is created with chmod 644.

    Host : OVH.

    No other performance plugins installed.

    Thanks.

    Plugin Author Konstantin Kovshenin

    (@kovshenin)

    Hi @chaplin89, thanks for reaching out!

    Could you also please confirm that WP_CACHE is defined in your wp-config.php file? As well as the directory where the plugin is installed (should be wp-content/plugins/surge).

    Thanks!

    Thread Starter billbennett

    (@billbennett)

    I’ve uninstalled Surge for now. No reflection on the plug-in, just that it doesn’t work with Pressable.

    Sorry Konstantin, that was a mistake on my part.

    wp-config.php was set to chmod 444 for security reasons. I set the default chmod back while I deactivate / reactivate Surge, and it works.

    Thanks for the plugin.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Site Health says caching not installed correctly’ is closed to new replies.