Support » Plugin: Wordfence Security - Firewall & Malware Scan » Site Health not working when Wordfence active

  • Resolved abrightclearweb

    (@abrightclearweb)


    I have the same problem as in this thread on a site I’m managing: https://wordpress.org/support/topic/wordfence-and-wp-5-2/. Accessing Tools > Site Health only shows the date and time.

    If I deactivate Wordfence, Site Health is accessible.

    I’ve looked at the blocked IPs in Wordfence -> Tools -> Live Traffic. There is only one, and it doesn’t match the server IP. I’ve whitelisted the server IP in the Advanced Firewall Options, but the problem remains.

    What else could you suggest to resolve this problem?

    The site is running WP 5.2.2 and Wordfence 7.3.4.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author WFSupport

    (@wfsupport)

    When you open the browser console while viewing that page do you see any errors in red?

    If you put the Firewall into learning mode and try accessing site health, what do you see?

    Tim

    Browser console says this:

    JQMIGRATE: Migrate is installed, version 1.4.1
    site-health.php:1 Unchecked runtime.lastError: The message port closed before a response was received.

    I tried putting the firewall into Learning mode. The same happened as when I looked at the Console: the Site Health page seemed to load momentarily and then went back to showing the date and time.

    Cloudflare is enabled on this site, and its IPs are whitelisted.

    Plugin Support WFGerroald

    (@wfgerald)

    Hey @abrightclearweb,

    I haven’t been able to reproduce this, but I’d like to suggest a few troubleshooting steps to at least narrow it down.

    Can you try disabling all browser extensions, and perhaps try a different browser?

    Can you try disabling all other plugins except Wordfence to test for a conflict?

    To do so I recommend the Health Check & Troubleshooting plugin which allows you to disable all plugins and switch to a default theme, but only for your user.

    Please let us know how it goes.

    Thanks,

    Gerroald

    abrightclearweb

    (@abrightclearweb)

    Hi,

    I’m not much further on, I’m afraid.

    I tried accessing the page in Chrome with extensions disabled. Same result.

    Then in Edge which has no extensions, the same again. Console messages:

    HTML1300: Navigation occurred.
    tools.php (1,1)

    HTML1527: DOCTYPE expected. Consider adding a valid HTML5 doctype: “<!DOCTYPE html>”.

    Using the Health Check & Troubleshooting plugin, after enabling it I tried to enable Wordfence and got this message:

    When enabling the plugin, wordfence, a site failure occurred. Because of this the change was automatically reverted.

    I tried enabling about another half dozen plugins and got the same message:

    When enabling the plugin, (plugin name), a site failure occurred. Because of this the change was automatically reverted.

    So that didn’t help much.

    I noticed when accessing the Site Health Info that a few bits of info didn’t display and said Loading…

    I don’t know if this is significant. The parts that didn’t load were:

    • WordPress directory size
    • Uploads directory size
    • Plugins directory size
    • Database size
    • Total installation size
    Plugin Support WFGerroald

    (@wfgerald)

    Hey @abrightclearweb,

    Thanks for the update, and additional information.

    Can you ask your host to increase your PHP resources and let me know if it helps?

    Can you also send me a Diagnostics report so I can get a better overview of your environment? Please navigate to Wordfence > Tools > Diagnostics. Here you can select SEND REPORT BY EMAIL. Please include your WordPress.org username and update this thread after you’ve sent it.

    Thanks,

    Gerroald

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Site Health not working when Wordfence active’ is closed to new replies.