Support » Fixing WordPress » Site hangs after login…

Viewing 10 replies - 1 through 10 (of 10 total)
  • First try changing themes to eliminate a theme problem.

    If that doesn’t solve it, using a ‘binary search’ approach to disabling the plugins can cut your testing time.

    • Disable half of the plugins.
    • If that works, enable half of those. If not, enable all of those and disable half of the others.
    • Repeat enabling/disabling half of the remaining ones to narrow down the group.

    If you start with 100 plugins, 5 tests will get you down to 3 possibles.

    LJagermaster

    (@the-living-legend)

    And once again the words “why didn’t I think of that?!” are hovering above my head! X-D Well, I did consider it the last time I had to play a round of ‘hunt the bug’ but given how temperamental wordpress is in general I assumed bulk activations/deactivations might not be a good idea – but I’ll definitely give it a try! 😀

    The sites theme is just as important as the features added by the plugins as I’ve spent months customising the design to achieve the look & feel I need for this site, so I’ll leave that as a last resort. But to be honest the fact that it loads fine to guests suggests that it’s more likely a plugin or config issue relating to registered users.

    Thanks though for the info, a bit short on time tonight but I’ll certainly give it a try over the next few days 🙂

    LJagermaster

    (@the-living-legend)

    Well that worked (not!) X-D The obvious problem here is accessing the plugins page in the first page, which I’ve been able to do once since starting this thread, then as soon as I clicked on the “Active” tab it hung again. I tried physically moving the plugins to another folder then opening the plugins page to see if that would help (since wordpress only automatically deactivates moved/renamed plugins after the plugins page is loaded) but nope, didn’t help.

    I’m aware it’s possible to deactivate plugins via the database (using phpMyAdmin for example), but I don;t want to risk mucking up the settings as well – anyone know of another way of successfully deactivating plugins?

    Have you looked at the database using an analysis tool. It might be possible that the database is corrupted somehow and needs to be repaired.

    LJagermaster

    (@the-living-legend)

    That was the first thing I did, but all results were returned as “OK”.

    Bizarrely though, as of last night the site’s been running fine while logged in – a little slower than it did before this all started but still only takes a few seconds for pages to load.

    However, I think I’ve realised at least what the cause may be. Every so often (approx. once per login session) I receive an “unresponsive script” alert box indicating it’s being caused by the “jquery.js” stored in the “/wp-includes/js/jquery” directory. Despite seemingly being able to access the backend pages with virtually no issues this alert did jump up at me a couple minutes ago. No other info is apparent to suggest more specific detail on this but if anyone’s came across this type of issue before and resolved it please let me know, as this may have been the cause all along… :-/

    Oh, and just an fyi for anyone using both the Ajax Easy Attendance List & Multi-Level Navigation plugins together, if your menu is messed up it’s being caused by a conflict with the attendance plugin (similarly if you use any Ajax reliant plugin with the Multi-level Navigation plugin you could experience the same issue), simply deactivate the attendance/ajax reliant plugin inform the developer. Accidentally discovered this while trying to resolve the initial problem… 🙂

    LJagermaster

    (@the-living-legend)

    Well, didn’t I talk way too soon! Both backend and frontend pages have stopped loading again – still convinced it’s the jquery issue, but as of yet haven’t found anything more specific. Will keep digging but any advice would be appreciated…

    LJagermaster

    (@the-living-legend)

    Oh this just continues to get better all the time! :-/

    While trying to narrow down what’s causing the initial issue, I decided to try to keep on top of setting the site up while I’m randomly able to access the admin functions. Updated some plugins (all of which I’ve been using for months and have all been running flawlessly – none of the updated plugins are suspects in this issue) and now all pages on the site – frontend and backend – show nothing other than this message:

    Sorry, but this plugin is not supported (and will not work) on WordPress MultiSite.

    Take a look for yourself.

    I can safely assume I won’t even be able to login next time I’m online, which means I’ll have to deactivate all plugins after all via the database. Just another wordpress related nightmare I guess! If anyone knows of an alternate solution though please share it… :-/

    Before you deactivate/delete all the plugins, can you search all of them for that message?

    LJagermaster

    (@the-living-legend)

    Well, took me 2 days to download all the plugins locally (ended up compressing the directory via cPanel then downloading/re-extracting – worked out much quicker than FTP! X-D ) and used Windows Grep to search inside all the files simultaneously – otherwise I’d still be searching this time next week – and no matches were found. Tried various search techniques including the most basic one possible but nothing was found.

    Just deactivated all plugins via the database (for those who want to know how to do this please see bottom of this post) and the site loads fine, if not a lot lighter in weight X-D I’ll try the bulk activation process and hopefully be able to identify which one/s causing this latest wordpress catastrophe!

    To deactivate plugins via the database:

    1. Open phpMyAdmin
    2. Select your sites database if you have more than one
    3. Click the “Search” tab at top of main page
    4. Type plugins into search box
    5. Click “Select All” beside list of tables & click Go
    6. Scroll down to wp_options table & click Browse
    7. Look for the active_plugins option & click the “Edit” link at far left of row
    8. Simply highlight the plugin/s you want to deactivate – if you want to deactivate all plugins highlight everything in the square box.
    9. Click “Go” & reload your site – you’ll see it load minus any widgets you were using with the plugins that you deactivated.

    NOTE 1: Before clicking “Go” on step 9 make sure you make a copy of the plugins that you removed from the box, as this makes it easier to reactivate them from the database if need be.

    NOTE 2: This will only deactivate the plugins, not delete them. If you wish to delete them outwith the admin interface you’ll have to do it manually via FTP or your hosting accounts web interface such as cPanel.

    LJagermaster

    (@the-living-legend)

    Ok, took much longer than I thought to get back on here but I finally narrowed it down to the Ban Hammer plugin. All other plugins are active again and so far (everything crossed) no login issues. Good news (at least for me ;-p ) is that I no longer need it as I’d only installed it to use with the Mingle Forum plugin, but now that the Symposium plugin is more or less stable enough to be used on a production site I no longer need Mingle at all.

    I can only assume it was causing the initial issue too, chances are I’ll never know for sure to be honest. But for the time being the site seems to be running fine so I’m back in business – until the next random bug anyway! 😉

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Site hangs after login…’ is closed to new replies.