• Resolved micha1981

    (@micha1981)


    Hello,
    your plugin works very well, but it seems as if I got a problem, migrating to another local IP:
    The local IP changed (different router). I updated WP (home, wp_url) and mysql database (posts etc.). I cleared the browser cache.
    The Browser still wants to load the old IP at some point (shows “Connecting to: OLD.IP”). It shows basically everything including GMW except the Map which takes like 5min to load. If I deactivate GMW everything works fine and fast. I couldn’t find any IP in GMWs Database.

    Do you think Geo-my-wp could be a reason for that, and how do I migrate it to the new IP then?
    Thanks
    Michael

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter micha1981

    (@micha1981)

    Hi again,
    I did some debugging on the site and found the reason. Here is the script from index:

    
    			jQuery( document ).ready( function($) {
    				$( '#wp-admin-bar-my-account-gmw-location' ).each( function() { 
    					$( this ).insertAfter( $( this ).next() ); 
    				});
    			});
    		</script>
    		<link rel='stylesheet' id='gmw-fl-search-forms-yellow-css'  href='http://<strong>192.168.178.42</strong>/wp-content/plugins/geo-my-wp/plugins/members-locator/templates/search-forms/yellow/css/style.css?ver=3.1' type='text/css' media='all' />
    <script type='text/javascript' src='http://192.168.2.186/wp-includes/js/admin-bar.min.js?ver=5.0.2'></script>
    <script type='text/javascript' src='http://192.168.2.186/wp-content/plugins/bbpress/templates/default/js/editor.js?ver=2.5.14-6684'></script>

    were 192.168.178.42 is the old IP. Any idea were it comes from?
    Thanks

    • This reply was modified 5 years, 3 months ago by micha1981.
    Plugin Author Eyal Fitoussi

    (@ninjew)

    Hello Michael,

    This seems to be related to the path of the search form and search results template files. Because the path is saved in the database, the plugin still uses the old path with the old IP address.

    Try this:

    1. Navigate to the dashboard -> GEO my WP -> Extensions, and deactivate then re-activate the Members Locator core extension. Doing so will refresh some data in the database.

    2. Navigate to the dashboard -> GEO my WP -> Forms -> Edit Form, and click “Save changes” to refresh the form data in the database.

    Let me know if this helps.

    Thread Starter micha1981

    (@micha1981)

    Hello Eyal,

    thank you for your answer. Now It works again!
    Deactivation + activation of the Members Locator core extension did it. Yesterday, I did even reinstall GMW without success.

    The 2nd tip, I tried intuitively two days ago – didn’t help.

    Thanks a lot for your help.
    Michael

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Site Hangs after Local IP changed’ is closed to new replies.