Support » Fixing WordPress » Site gone away

  • Resolved fashioneyer


    Hi, I have a really urgent prolem.

    My site wasn’t showing the pictures in their real size and I searched the forum for an answer an came across this:

    “Q: Why can’t I post “full size” images correctly? Why does WordPress always limit them to 500 pixels wide?
    A: Your theme has not been updated to use the new image scaling features properly. WordPress 2.5 allows themes to specify the width of their main content area. The reason for this is that people were commonly posting straight camera photos and then getting annoyed when their images made the blog super wide. All you have to do is add one line to your theme to make it compatible. Add this line to the theme’s functions.php:
    $GLOBALS[‘content_width’] = 800;
    Replace 800 with the maximum width you want to allow an image to be in the main blog area.”

    So I did exactly this. I must say that I do not understand the first thing about html but I gave it a shot. The first time I tried, nothing happened. So I asked a friend for help, but since she was not available I tried it again. But this second time, when I pressed the “Update File” button, this message appeared: “Parse error: syntax error, unexpected ‘$config’ (T_VARIABLE) in /home/fashione/public_html/wp-content/themes/sliding-door/functions.php on line 94”

    I took it off and pressed the button again but the message kept appearing and now I’m kinda desperate because I don’t know what to do anymore. If anyone enters my site this is what it show instead of my page. And I can’t go anywhere else in the edit page, everything I try to do, this message shows up.
    I would really appreciate any help you could give me, please.

    Thank you all.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Site?

    Christine Rondeau


    Volunteer Forum Moderator

    I think that what you will need to do is access your site via FTP. Grab the files from your theme folder and make a back up.

    Then open the functions.php file in a text editor and remove the line you added to your functions.php file.

    That functions file is pretty important and contains mostly php functions. It can lead to your whole site going down if there are erros — as you are experiencing right now. It’s totally nerver racking… I’ve been there.

    So if you are going to fiddle with it, make sure you make a backup first and have your FTP info handy so you can restore it.

    My site is

    Christine, I don’t know how to access my site via FTP. I’m a complete noob!

    I already erased the line I added but nothing happened. It still shows the same error message. The code part that appears to have an error is this

    	 * Array of configuration settings. Amend each line as needed.
    	 * If you want the default strings to be available under your own theme domain,
    	 * leave the strings uncommented.
    	 * Some of the strings are added into a sprintf, so see the comments at the
    	 * end of each line for what each argument will be.
    	$config = array(
    		'domain'       		=> $theme_text_domain,         	// Text domain - likely want to be the same as your theme.
    		'default_path' 		=> '',                         	// Default absolute path to pre-packaged plugins
    		'parent_menu_slug' 	=> 'themes.php', 				// Default parent menu slug
    		'parent_url_slug' 	=> 'themes.php', 				// Default parent URL slug
    		'menu'         		=> 'install-required-plugins', 	// Menu slug
    		'has_notices'      	=> true,                       	// Show admin notices or not
    		'is_automatic'    	=> false,					   	// Automatically activate plugins after installation or not
    		'message' 			=> '',							// Message to output right before the plugins table
    		'strings'      		=> array(

    thank you for your help, my programmer resolved it for me.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Site gone away’ is closed to new replies.