WordPress.org

Forums

WooCommerce - excelling eCommerce
[resolved] Site freezes at checkout (10 posts)

  1. gundog88
    Member
    Posted 2 years ago #

    I'm currently testing my store, but whenever I complete the transaction and checkout, the screen gets stuck. I expect a message to pop up confirming that the order has been placed, along with the customer message relevant to BACS payment, but nothing happens. When I refresh the screen it just shows the same page with no content.

    My store is here: http://www.timothyandclover.co.za/market/

    http://wordpress.org/extend/plugins/woocommerce/

  2. Mike Jolley
    Member
    Plugin Author

    Posted 2 years ago #

    WooCommerce > System status - check for issues there. Could be a page not setup.

  3. Coen Jacobs
    Member
    Posted 2 years ago #

    You are using a very old version of the Simplicity theme. Please update (or download via your My Account view and overwrite the files on your server).

    If that doesn't fix your issue, please disable all plugins except for WooCommerce and see if that resolves it.

    It's most likely a Javascript error that blocks the redirect after checkout. Have you checked your browsers console for any errors for when it freezes?

  4. gundog88
    Member
    Posted 2 years ago #

    Thanks for the replies.

    I updated my theme earlier this week and according to my dashboard it is up to date. I tried deactivating all plugins except for WooCommerce - the site didn't freeze when I placed the order, but instead showed a strange screen that said "checkout" at the top, but with a message below to me (not the customer) to say that a new order had been placed. The message also included the following text:

    "Fatal error: Class 'order_item_meta' not found in /home2/timotij4/public_html/wp-content/themes/simplicity/woocommerce/emails/email-order-items.php on line 14"

    I've checked system status and all pages seem to be set up, including the "order received" page which doesn't appear when I click on "place order". I also expect a message to appear to the user regarding BACS payment, but nothing appears.

    How do I check my browser console for errors?

    Thanks again for your help.

  5. Coen Jacobs
    Member
    Posted 2 years ago #

    You are currently running version 1.7 of the theme. The latest available stable version is now version 1.11.7. Please log into your woothemes.com account, download the latest files from the My Account page and replace your theme files with those new files.

  6. gundog88
    Member
    Posted 2 years ago #

    Hi Coen, I'm using Simplicity by Olegnax, not WooThemes

  7. Coen Jacobs
    Member
    Posted 2 years ago #

    Right, can you please rule out the theme being the cause of your problem by temporarily setting a standard WordPress theme like Twenty Twelve as your theme? Let me know if the problem is still there when you make an order with a default theme set.

  8. gundog88
    Member
    Posted 2 years ago #

    Hi Coen,

    I setup Twenty Twelve and the whole process worked perfectly. It's obviously a problem with my theme, which the developers are apparently aware of. I will have to wait for them to release an update addressing the issues.

    Thanks very much for your help.

  9. Matthew Kinneman
    Member
    Posted 1 year ago #

    Hello Gundog, I see that the website is up and running using the Simplicity theme still. We too are running into the same exact issue with the screen freezing up after you hit the PLACE ORDER button (https://vitaminsforpitbulls.com). Orders go through but a confirmation page never shows up. Can you please let me know what you did to resolve this issue? Really appreciate any tips you can share.

  10. gundog88
    Member
    Posted 1 year ago #

    Hi bullymax,

    My issue turned out to be a theme one - Simplicity by Olegnax hadn't been updated to be compatible with the latest rendition of WooCommerce and there were compatibility problems. Since Olegnax released the new version of Simplicity that was compatible with WooCommerce 2 things have worked perfectly. As far as I could see when I trawled the wordpress support pages for people with similar problems, the theme was often where the problem lay - I would recommend going back to your theme's designers.

    I don't think I've been much help, but I hope you get your issues resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags