Support » Plugin: LiteSpeed Cache » Site fails to redirect regularly

  • Resolved Merv Renton

    (@m3rvrent0n)


    This wordpress site regularly and randomly fails with:

    The page isn’t redirecting properly

    An error occurred during a connection to provenlines.com.au.

    This problem can sometimes be caused by disabling or refusing to accept cookies.”

    WordPress Admin still works, thankfully!
    I found that clearing the LScache fixes it.
    e.g. updating any plugins etc, which clears the cache.
    or just clicking save on LScache settings if there are no updates needed will fix it.

    It’s pretty annoying, as it can happen any time. sometimes more than once a day.

    I have enabled Debug on LScache for admin IPs in the hope that will give more information.

    Does anyone have any suggestions as to the solution to this?

    Thanks,

    Merv

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • stanley@litespeed

    (@stanleylitespeed)

    Hi @m3rvrent0n, may I know have you use any redirect plugin for the site? Also, is this issue showing after a period of time after purging the cache?

    Simon

    (@simonskaar)

    I had the same issue at hostgator but now I moved to an hosting in my country with LiteSpeed and it works (for some reason I don’t know!). Now I use PROISP (https://www.proisp.no/webhotell/ medium with litespeed).

    I’ll pop back if the issue occurs here too!

    Merv Renton

    (@m3rvrent0n)

    Hello @stanleylitespeed thanks for helping.

    The Plugins List is:
    Block Bad Queries (BBQ)
    Disable Comments
    LiteSpeed Cache
    Meta Box
    Redux Framework
    Slider Revolution
    WooCommerce
    Wordfence Security
    WP Rollback
    WPBakery Page Builder
    WPS Hide Login
    Yoast SEO
    Yolo Sofani Framework

    The issue happens from 2-3 times a day to maybe every second day.
    It seems to be quite random.
    I am glad I worked out I can easily purge the cache.
    – But it needs to be fixed.
    Recently it happened at least these times as reported by a site checker:
    12/11/2019 x2
    14/11/2019 x2
    16/11/2019 x1
    21/11/2019 x2
    23/11/2019 x1
    24/11/2019 x2

    Merv

    • This reply was modified 10 months ago by Merv Renton.
    stanley@litespeed

    (@stanleylitespeed)

    If next time you meet the issue, can you save the HAR content for debugging? It requires you to turn on the inspector every time when you load the page to keep the log.

    Here’s a solution before finding out the reason, please try to set LiteSpeed Cache Setting > General > Default public Cache TTL to 86400 (1 day). If you want to keep the cache warm, you can use LiteSpeed > Crawler.

    Merv Renton

    (@m3rvrent0n)

    Thanks @stanleylitespeed for the suggestions.

    The Default public Cache TTL was 28800, so I have made it 86400
    – What’s the benefit of caching for longer?

    I have read about HAR
    and I have enabled Debug on LScache for admin IPs which might help, too.
    – although my IP changes from time to time, so I have to remember to update.

    Merv

    stanley@litespeed

    (@stanleylitespeed)

    Oh, you already set 28800, please just ignore my suggestion. Could you help me to check when the redirecting error occurred, the page is under X-LiteSpeed-Cache: hit or miss? You can find it on the response header.

    Merv Renton

    (@m3rvrent0n)

    Thanks for that info @stanleylitespeed .

    OK, I have set it back to 28800 and updated plugins, so the cache is cleared.

    I then tried to see the X-LiteSpeed-Cache: hit or miss under normal circumstances when the site was working.

    I used Chrome and guidance from this page:
    https://my.kualo.com/knowledgebase/109_litespeed-cache/1361_verify-if-litespeed-cache-is-working.html

    After refreshing several pages and viewing Network / All I cannot see the lscache.kgix.com entry in the Name column.

    I tried this on another WP site also using the cache and could not find the lscache.kgix.com entry there, either.

    What am I missing here?

    Problem Site is https://provenlines.com.au/

    Thanks,

    Merv

    • This reply was modified 10 months ago by Merv Renton.
    stanley@litespeed

    (@stanleylitespeed)

    You should find your domain “provenlines.com.au” on the network tab. Also, you need to open the network tab before you reload the page to record the data transition.

    Plugin Support LiteSpeed Lisa

    (@lclarke)

    Hi @m3rvrent0n,

    Do you still need help with this? If so, please let us know.

    I’m going to mark this topic “Resolved” for now, but will re-open it if we hear from you again.

    Thanks!

    @lclarke it has not failed since the last time I reported it!

    Maybe an upgrade of the LiteSpeed Plugin has fixed the issue.

    I will continue to watch the site, but please close this for now.

    Thanks for your help.

    Merv

    Plugin Support LiteSpeed Lisa

    (@lclarke)

    Glad to hear it! We’re here if you need us again later.

    Cheers!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Site fails to redirect regularly’ is closed to new replies.