Support » Plugin: Wordfence Security - Firewall & Malware Scan » Site down (Error 504) when activating Wordfence

  • Resolved pattihis

    (@pattihis)


    Hello,

    I’ve been using this great plugin for years in dozens of wp sites with no problems and I’m very happy with it.

    Yesterday however, one of my websites went down and after hours of trying to find the problem I figured out that when I disable Wordfence site is running great. If I enable Wordfence website goes down and I get timeout errors in my log files (please see sceenshot):

    http://prntscr.com/jfw48d

    Any ideas on how to fix this time-out error caused by Wordfence?

    Thank you

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi, my super amazing helpful hosters just helped me with this. Wordfence has something strange with its Live Traffic View. The strange thing, we haven’t touched this plugin for months, but the last 24 hours, knocked our whole cloud server offline. Apparently, its been happening to a number of sites too, so the awesome team at wordfence could have a look that would be awesome.
    Simple disable live traffic view, and your ram should come back to normal shortly. Hope it helps.

    On a side note, this plugin is amazing! Like, incredibly amazing!

    • This reply was modified 2 years, 2 months ago by seannikilabs.

    Thank you for your reply. I run a 4-core 16GB-RAM CentOS VPS with just 30 WP websites on it. Never had any problems about performance before since this VPS is way more powerful than I really need.

    The website I mention on my original post is the one with the most traffic (about 3000 visitors/day) and I guess that is why it went down first. I notice however problems with my other websites too, all had Wordfence installed.

    I deactivated Wordfence in all my websites and now my server’s resource usage is back to normal. I do not however feel comfortable without my favorite firewall/security plugin on.

    Please Wordfence team, could you have a look at this…

    Same here. The website was down starting on the 8th of May, but we were also getting an abnormal amount of traffic as well. 5.5 mil requests according to Cloudflare. Not 100% sure that it’s linked but seems like it’s a possibility.

    • This reply was modified 2 years, 2 months ago by zoldor.

    Could you be experiencing the same issue as that discussed in this topic?

    Yes, exactly as mentioned in that topic. I have already turned off Live Traffic in all my websites and server seems ok for two days now. Glad they found out that it is a conflict with Rocket Loader, I did had that turned on in Cloudflare.

    I will be deactivating Rocket Loader too for all sites till they resolve it. Good to see both teams working on this already, thank you very much for sharing that post.

    Hi again, I just discovered another issue we have, and you may have it too just in case. Ever since this started, our checkout doesn’t work on Internet Explorer. I’m a chrome and firefox guy, and works fine on safari too, but since this, none of the Internet explorers will show our checkout, so you might want to check your sites on IE. I’ll let you know if I find the cause and/or solution as soon as I find it. I run an E-commerce site that sells a lot, but the since Friday, nothing on Internet Explorer and some good customers informed me of this issue.

    and yes same here, im running clourdflare and rocket loader.

    Hi,
    I suggest keeping an eye on this thread, it turned out that this issue happened due to a recent update of Cloudflare Rocker Loader, turning it off for now or switching off Wordfence Live Traffic would help, I recommend reading MattR reply on this thread regarding this issue as well.

    Thanks.

    Awesome! Yep I turned off rocket loader, turned off a new thing called batimore, baitly? something like that and turned off my JS compression, everythings back to normal, im going to try and get wordfence back on tonight. Thank you for the update Wfalaa.

    ps, Still Loving this plugin by the way 😉

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Site down (Error 504) when activating Wordfence’ is closed to new replies.