Support » Plugin: Query Monitor » Site doesn’t work on front-end and slow in admin when plugin is activated

  • Greetings,

    I would like to ask for your help please.

    I’m running a website with WP+WooCommerce. Website runs on PHP 7.2 and Nginx.
    When activating Query Monitor, I can’t access front-end. It takes an endless time and Nginx logs show a 110: Connection timed out (means 504 Gateway Time-out).

    That said, I don’t know how to trace back what’s causing no response. It only happens when the plugin is activated. On the admin panel, it’s really slow and I ended up deactivating the plugin after multiple attempts. Tried that scenario multiple times.

    Also, I noticed when I click Query Monitor > Queries, the browser becomes really slow on this tab and when queries are shown, everything is slow and I can’t click anywhere.
    No errors provided in the JS Console.

    What could cause this ?
    I have a powerful server and I set and increased all needed Nginx/MySQL/PHP/OPCache options.

    Thank you.
    NadimD

    • This topic was modified 1 month, 4 weeks ago by  nardoum.
    • This topic was modified 1 month, 4 weeks ago by  nardoum.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    It sounds like your site may be performing an exceptionally high number of database queries. When QM attempts to log these and show them to you, it causes the timeout and causes your browser to freeze.

    What numbers does QM show at the top of its admin menu? For example, 0.30S 5,329kB 0.0114S 61Q

    Thank you for answering !

    Here is the full output on the extensions page (with wp-performance enabled) :
    2,23s 75 002kb 0,4471s 220Q

    On the WP Admin Homepage (with wp-performance enabled) :
    2,53s 101 964kb 1,2826s 317Q

    I noticed a single AJAX request fail coming from wp-performance.
    Disabling wp-performance made the site work. Still slow. When re-enabling wp-performance, it’s slow again and front-end inaccessible.

    On the front-end homepage (with wp-performance disabled) :
    3,83s 101 584kb 0,3823s 189Q

    Notice that opening Queries is also making the browser slow when wp-performance is disabled.

    Is that large ?

    I can see 3 queries each taking up to 0.0628s, 0,0575s and 0,0624s.
    The second one is wpml-string-translation and fetches 4395 rows.

    Browser tab completely crashes and I’m unable to close it and see further informations.

    FYI, here is the list of active plugins :

    • sitepress-multilingual-cms
    • all-in-one-wp-migration
    • better-admin-bar
    • caldera-forms
    • custom-fields-gutenberg
    • duplicate-page
    • user-role-editor
    • wc-builder-divi-premium
    • wc-fields-factory
    • woocommerce-gateway-stripe
    • woocommerce-menu-bar-cart
    • woocommerce-multilingual
    • woocommerce
    • wordpress-importer
    • wordpress-seo
    • wp-mail-smtp
    • wpfront-scroll-top
    • wpml-media-translation
    • wpml-string-translation
    • wpml-translation-management
    • This reply was modified 1 month, 4 weeks ago by  nardoum.
    • This reply was modified 1 month, 4 weeks ago by  nardoum.
    • This reply was modified 1 month, 4 weeks ago by  nardoum.
    • This reply was modified 1 month, 4 weeks ago by  nardoum.
    • This reply was modified 1 month, 4 weeks ago by  nardoum.
    • This reply was modified 1 month, 4 weeks ago by  nardoum.
    • This reply was modified 1 month, 4 weeks ago by  nardoum.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.