Support » Plugin: Polylang » Site does not open after adding menu's

  • Resolved pimdepom


    permalinks settings: year, month, day and name
    no static front page
    Polylang settings: cannot see then; Polylang disabled now
    Theme: Twenty Eleven, version 1.5

    I wanted to create two menu’s. I did the following as in your documentation:
    You can create one menu per language (2 languages in my case) in the WordPress menus page (that is what I did). Then go the menu tab in the language settings page and affect the right menu to each language.

    After that I opened my site and got the following error:

    Warning: rtrim() expects parameter 1 to be string, object given in /home/deb39552/domains/ on line 1381

    Warning: Cannot modify header information – headers already sent by (output started at /home/deb39552/domains/ in /home/deb39552/domains/ on line 876

    I removed the WP menu’s and reset the menu settings of Polylang (unchecked every setting), but the error does not go away. The only thing that helps is Deactivating Polylang.

    What can I do to activate Polylang without getting this error.

    Currently Polylang is disabled, so if you got to my site you will see the content and the languages posts are all visible in one page.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Chouby


    Polylang should work out of the box with Twenty Eleven, but may conflict with another plugin. Try finding which one it is.

    Polylang did work out of the box with all the other plugins and with Twenty Eleven. But it didn’t after I experimented with the menu’s. So no complaint about Polylang until now.
    I deactivated all my plugins. Then I activated Polylang and had the same problem as reported above. When opening my blog I get the (PHP) errors messages. When I deactivate Polylang I can open my blog again.
    Can I de-install Polylang and install it again? Will all posts, tags and categories stay in the database?

    I tied something else. I changed the default language in the settings tab of Polylang from Dutch in English. Then my blog opens normally. Then I changed it back to Dutch and the blog is still OK.
    I expected that a little change somewhere could solve the problem, because it has worked before. It’s solved now.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Site does not open after adding menu's’ is closed to new replies.