Support » Plugin: MainWP Child » Site disconnected, won’t reconnect

  • MainWP Dashboard version: 3.4.7
    MainWP Dashboard WordPress version: 4.9.5
    MainWP Child version: 3.4.7
    MainWP child site WordPress version: 4.8.6

    I was able to connect that child site once, in the first try. However when trying to update first plugin site disconnected.

    Since then I have not been able to reconnect.

    I got these messages interchangeably:

    Error - This site already contains a link. Please deactivate and reactivate the MainWP plugin.
    Hint: Go to the child site, deactivate and reactivate the MainWP Child plugin and try again.

    No MainWP Child plugin detected, first install and activate the plugin and add your site to MainWP afterwards. If you continue experiencing this issue please test your connection here or post as much information as possible on the error in the support forum.

    The AJAX request mainwp_checkwp always returns:

    {"response":"OK","check_me":null}

    So the problem is in the next requests.

    I’ve tried disabling / enabling child plugin as well as removing completely and reinstalling. I’ve also removed any traces from the database of the plugin (weird these were not removed on plugin removal).

    Also removed the site from dashboard but have never been able to re-add successfully.

    Can you please share how can I debug this manually? Any technical details much appreciated. Unfortunately sharing FTP / wp-admin access with your support is not the case.

    PS. Amazing job!

    Krzysztof

Viewing 2 replies - 1 through 2 (of 2 total)
  • @cih997, thanks for reaching us.

    I have seen this kind of issues before and in all cases, it was a conflict between the MainWP Child plugin and some 3rd party plugin/theme. For the start, please try to deactivate all plugins on your child site and activate only the MainWP Child. Also, try to switch the site theme to one of the default WP themes. After that try to reconnect your site and sync.

    If that doesn’t help, please open a helpdesk ticket at https://mainwp.com/support/. We will be happy to continue troubleshooting this issue for you.

    Plugin Author mainwp

    (@mainwp)

    Krzysztof Dryja, if you are still experiencing the issue please follow Bogdan’s directions from above and open a ticket with the support team.

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Site disconnected, won’t reconnect’ is closed to new replies.