Support » Plugin: dsIDXpress » Site Crashes with Upgrade to Version 3.5.0 of dsIDXPress

  • Resolved linux4me2

    (@linux4me2)


    I upgraded to version 3.5.0 of dsIDXPress and my site crashed. No page would load, not even the admin pages. When I looked at the error log, I found the file was up to 390+ MB and climbing. It had taken up all the allotted disk space for the account, and was preventing any page from loading.

    A look in the error log showed the issue was that the PHP function curl_multi_exec was disabled on the server. According to dsIDXPress Tech Support, version 3.5.0 of the plugin uses a WordPress asynchronous curl function to increase performance when there is more than one widget or property listing on a page. The WordPress function apparently tries to use curl_multi_exec without first checking to see if the function is enabled.

    The fix was to remove curl_multi_exec from the disabled functions list on my server.

    If you’re on a WHM/cPanel server, and have access to WHM, the function needs to be removed from php.ini (Home -> Software -> MultiPHP INI Editor -> Editor Mode), and if you’re using PHP-FPM, it also needs to be removed from the disabled functions list in Home -> Software -> MultiPHP Manager -> System PHP Configuration. You’ll need to restart Apache and PHP-FPM Service for Apache to make the changes active.

    Version 3.5.0 noticeably decreased page load times on my site, so it’s well worth installing the upgrade, but if you have the access, I would check to make sure that the PHP function curl_multi_exec is enabled on your server.

    I didn’t see anything about curl_multi_exec in my phpinfo() file, so you might try using the following PHP file to check to see if it’s enabled on your server:

    
    <?php
    	if (function_exists('curl_multi_exec')) {
    		echo 'curl_multi_exec is enabled';
    	} else {
    		echo 'curl_multi_exec is not enabled';
    	}
    ?>
    
    • This topic was modified 4 months, 2 weeks ago by  linux4me2. Reason: Marked it resolved
Viewing 1 replies (of 1 total)
  • Plugin Author LindzConnell

    (@lindzconnell)

    hi @linux4me2

    We appreciate the info and are glad you were able to chat with Tony from our Support Team this morning.

    And we’re glad you were able to quickly find a solution to fix this server/host setting on your end.

    Have a great day!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.